12

Server is working perfectly but when I do RDC screen is only black. This happened before and I fixed it by powering off the server via KVM/IP, but I don't want do that again. How can I fix this issue.

OS: Windows Server 2008 R2 Web Edition SP1

2

17 Answers 17

3

I've seen this happen before 3 or 4 times when a user just closes their session instead of logging out of it. Please try the things in the KB article above under JohnThePro's answer.

13

This often happens to me when I connect to Windows 7 x64 machine. Solution that I use is pressing Ctrl-Alt-End in the RDP window. This brings up the "lock your computer" screen. Lock-Unlock and you are in!

5
  • 1
    This does the job. Ctrl-Alt-End and started task manager. Jan 23, 2019 at 7:15
  • You're probably not on stack anymore but thank you, it still work just fine in 2019. I wasn't sure what to do since Ctrl-Alt-Del was not working on the remote desktop.
    – Gainz
    Nov 5, 2019 at 19:25
  • 1
    @Gainz - I'm still here, not as often as before though ;)
    – demp
    Nov 7, 2019 at 12:03
  • wow. this almost worked except after inserting the password to unlock I get to the same balck screen! oO
    – Zac
    Oct 28, 2021 at 8:21
  • 1
    Surprisingly, task manager came up (over a black screen)
    – Zac
    Oct 28, 2021 at 8:27
6

Next time it crops up, there is a specific KB article about this issue.

http://support.microsoft.com/kb/555840

SYMPTOMS

While logon into a remote server by using remote desktop, the following issues may occur:

  1. A slow logon process.
  2. A black screen appear for a while, until the regular desktop appear.

RESOLUTION

  1. Disable the use of "Bitmap Caching" on the RDP client.
  2. Verity that the server, client and the network equipment using the "MTU" size.
0
5

Here is how to work around the issue. All the above else failed for me.

I am using Windows 7 home Edition.

Before Connecting To RDP,

Click the link with the words "Remote desktop Connection" Link. Ensure you click the link with these words, not the actual URL or saved RDP name.

When the RDP window opens up, click the Options button at the bottom.

Change to Display properties by clicking the Display Tab.

On the Display Configuration Panel, Change the Screen Resolution slightly each time before clicking Connect.

This will ensure your black screen stays away.

4

Press CTRL + ALT + END and hit the Task manager. Log off and log in back again. It happens if user disconnects the session but not log off properly.

2
  • Didnt even have to log off, it just made everything appear
    – citynorman
    Sep 24, 2020 at 1:01
  • Wonderful! Another thing you can do is whilst Task Manager is visible, click the Process tab, then File menu, Run new task > explorer.exe. BAM! Windows Desktop with Taskbar re-appears :)
    – MickyD
    Apr 22, 2021 at 1:24
2

I had a similar problem with Windows Servers (a mix from 2012 to 2019):

VMware console is black, RDP connection is black and it even happened with a physical server (but only domain joined servers). No way to get into safe mode: always black.

Server works OK, services run normally and can connect remotely with powershell and WindowsAdminCentre and my usual remote tools. Just no GUI.

Only chance to get them back to normal was to overwrite the C:\WINDOWS\SYSTEM32\CONFIG\SOFTWARE registry from backup C:\WINDOWS\SYSTEM32\CONFIG\REGBACK\SOFTWARE (server has to be powered off), but that not always worked.

So I've examined a server with process monitor (procmon.exe) and noticed a lot of overflow errors related to registry "HKLM\software\microsoft\windows nt\currentversion\fonts".

I deleted all non Windows standard fonts (my company had a policy to add some corporate fonts) from registry hive "HKLM\software\microsoft\windows nt\currentversion\fonts" and it started working inmediately.

Even if the cause of registry corruption may be different for different users, procmon showed me what was wrong.

Hope it helps!

1

Have you tried logging in as a different user? This happens sometimes on my terminal when a session gets stuck logging out. Ending the session from the remote desktops tool fixes it.

1

Found this article it list quite alot of possible reasons and their solutions regarding this issue, I was able to fix my issue with by enabling sessions limits as described in the article. http://www.grishbi.com/2015/01/rdp-black-screen/

2
  • So what actual change did you implement? That article may disappear next week, next month, or next year.
    – Hyppy
    Jan 21, 2015 at 19:40
  • @karan Like Hyppy mentioned - "What actually fixed the problem?" This site is a great tool, in that information referenced elsewhere can still be found, as long as someone puts that information in the answer.
    – Signal15
    Jan 21, 2015 at 20:15
1

There is also another KB article with a patch for Windows Server 2008 R2.

http://support.microsoft.com/kb/981156/en-us

I installed this patch to solve the issue.

When a user session is disconnected, the black screen showed up occasionnaly on reconnection.

2
  • This linked support item is for Windows Server 2008 R2 not for Windows Server 2012 as mentioned in the answer. Jan 29, 2015 at 5:59
  • Sorry, this was a typo. We are using only Windows 2008 R2. Jan 29, 2015 at 6:14
1

I had a similar issue remoting into a desktop running Windows 10. The desktop had 2 monitors, one plugged into the on-board graphics and one in a dedicated graphics card. Unplugging the monitor that was using the on-board graphics fixed the issue... presumably something in one of the drivers isn't playing nicely.

1

Try to get it in full screen mode and then do an alt + tab Maybe it's stuck in a weird application. This technique worked for me once.

1
  • does not solve. anyway i did a kvm/ip power off and power on since i needed a solution asap. so can not test answers anymore :( Jan 9, 2011 at 22:27
1

When windows 10 goes into the blank screen on RDP --> Ctrl+Alt+end ---- this takes to screen where you can see Task manager
--> Start task manager
--> run new task cmd.exe

taskmanager window

--> To initiate a Restart, type:
shutdown /r /t 0 then press Enter

0

UAC. UAC is the problem. That bullshit, yes. In my case the first login was successful and working, but any other consecutive attempt was not working. I was getting either a flickering(unusable) or completely black screen, on RDP or directly on the console of the 2012 R2 server. In the Application eventlogs there were lots of errors with eventID 1000(Faulting application name: explorer.exe, version: 6.3.9600.17415, time stamp: 0x54503a3a Faulting module name: unknown). UAC was disabled. I just enabled it, reboot the server, and then I was able to log in with multiple working sessions. I even disabled back UAC and reboot the server again and things were working normally. Beware of UAC :)

0

I really don't know this happened to my server but I clicked the blank screen and typed in my password. Boom, it opened up. So I think, in my case, the login screen was not being displayed.

0

Many people, including me and many, have problems with this. However, there is a lot of information full of confusion. An easy way for those who have this problem in ARP connection. This problem is mostly caused by the ARP connection being left open.

SOLUTION: FOR DC SERVER: Write a rule from Server GPO. In case of disconnection or exit, log out within 5 minutes. Hello to everyone, If there are programs that need to remain open on the current server, apply the rule only for computers that will connect.

*Note! * Doing 5 minutes will minimize possible risks.*

TERMINAL SERVER: Apply the rule you will create on the DC Server only for the terminal server or apply it to the users who will connect.

If you have difficulty in creating rules, just write an answer.

0

I've had this just now. Rdp and see the login prompt and virtual keyboard but as soon as i've authenticated i just see black. Tried locking and unlocking and was the same. Ctrl+alt+end gets me the task manager though. What got me back up was while in task manager i clicked File > Run new task then executed explorer.exe and things came back to life. Hope this helps someone else.

0
  1. Set the RDC display options to "Full Screen" (usually the default).
  2. Press "Ctrl + Shift + Esc" to bring up the task manager.
  3. In the task manager app, click File -> Run new task
  4. Type "explorer" and press enter.

After following the above steps you should be able to see the Desktop load completely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.