0

When I run the following

[root@host plugins]# ./check_hpjd -H printer1.mydomain.com : Timeout from host printer1.mydomain.com

I have Net-snmp installed on my system, I noted that i didn't have net-snmp-utils installed, and then I was able to run

[root@host plugins]# snmpwalk -Os -c public -v 1 printer1.mydomain.com system

sysDescr.0 = STRING: HP ETHERNET MULTI-ENVIRONMENT sysObjectID.0 = OID: enterprises.11.2.3.9.1 sysUpTimeInstance = Timeticks: (325408663) 37 days, 15:54:46.63 sysContact.0 = STRING: sysName.0 = STRING: printer1 sysLocation.0 = STRING: sysServices.0 = INTEGER: 72

So I know that the printer is working as expected, (as far as SNMP is concerned). But when I run

[root@host plugins]# ./check_hpjd -H printer1.mydomain.com -C public Error in packet ()

I get this error - From what I've tried so far, I know my host can communicate via SNMP, I know the printer responds via SNMP, so I guess I'm left to look at the plug-in, which I will be checking up on. I'm new to SNMP, I am investigating this with my good friend Google search, but I am on a learning curve here, so please forgive my questions if they sound stupid,

0

My printer is not 100% JetDirect compatible! GRRRRRR!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.