0

I briefly configured branch router Cisco 2911 and saved config.

Unfortunately - after rerun Cisco needs "copy startup-config running-config" to read configuration (I really need this - for example to get up interface GigabitEthernet0/0).

How I can save my configuration as the permanently one and auto started?

1
  • 3
    Answer is here - registry cisco.com/en/US/products/hw/routers/ps233/… """In this example, the configuration register shows 0x2142. The router bypasses the startup configuration stored in NVRAM during its boot sequence. This feature is normally used during a password recovery procedure.""" So, the correct answer is to change registry.
    – bluszcz
    Jan 11 '11 at 14:12
2

As told by bluszcz in the comment to your question, please take a look to Configuration register value in the output of show version It should be set to 0x2102 which you can do with the config-register 0x2102 command

2

btw:

copy startup-config running-config

does not replace the current running-config with the startup-config, but merges both into a running-config...

If you need to replace your current-config (e.g. rollback configuration-mistakes), you need to reboot the device or use "configure replace".

tsg

1

If I'm understanding what it is you're asking, you need to execute a "copy run start" to save your running configuration to the startup configuration.

3
  • No, this one doesn't work. I still have to read manually my config.
    – bluszcz
    Jan 11 '11 at 13:35
  • @bluszcz Ok, I'm lost. "copy run start" is the correct way to save a config. Then when you issue a "reload" or the device is power cycled the config you saved is the config used on boot. Jan 11 '11 at 13:58
  • Answer is here - registry cisco.com/en/US/products/hw/routers/ps233/…
    – bluszcz
    Jan 11 '11 at 14:07
1

How I can save my configuration as the permanently one and auto started?

copy running-config startup-config

1
  • I will check in 1-2 hour and post result - I think that I saved it in this way before, but maybe I was wrong
    – bluszcz
    Jan 11 '11 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.