I have setup a secure wireless network which works very well except for two laptops running Ubuntu 10.10 that can't access the Internet via a browser at the same time. They can both ping sites, wget sites, use skype but when using a browser the page never loads (in Firefox the status bar just sits there saying "Connecting" until it times out.)

Here is what we have tried so far (nothing has fixed this issue):

  • OpenDNS
  • Restart networking services
  • Using wired connection rather than wireless
  • Removing all other nodes from the network except the two machines that have this issue
  • Swapped out the router
  • Factory reset the router
  • Reformatted one of the machines and re-installed Ubuntu 10.10

Other things that we have checked:

  • The two machines can connect simultaneously without any issues to other wireless networks in different locations (say in an Internet Cafe or another office)
  • The two machines have unique IP addresses
  • The two machines have unique MAC addresses
  • The two machines can communicate on the network using Skype, wget, ping etc
  • We are not using a proxy on either machine

FYI: I have attached output from wireshark. For the test we turned both machines on and pointed them both to the same website. The content loaded on one and not the other. Here is the output from wireshark- (speedyshare.com/files/26228631/machine_output_1 && speedyshare.com/files/26229335/machine_output_2). As you can see the first one worked, the second one didn't.

I don't fully understand the output and would appreciate if someone could shed some light on what might be causing this and how we can fix it!

Many thanks!


  • It would be helpful if you could upload the raw pcap file for the second machine, eg in the same format that you uploaded for the first one – Daniel Lawson Jan 13 '11 at 8:03
  • Sorry, I should have done that! Here it is: speedyshare.com/files/26229335/machine_output_2 (updated in question too) – jensendarren Jan 13 '11 at 8:53
  • Have you got a firewall? Is http traffic being blocked from 1/both of these laptops? – AliGibbs Jan 13 '11 at 9:13
  • No firewall. HTTP not blocked from either laptops. Everything works fine as long as we are not connected to the network at the same time - then only one of us can browse web pages and the other can not. Did you check the machine outputs that I uploaded? I notice that the outputs are quite different from each other. Perhaps that contains some clues? – jensendarren Jan 13 '11 at 10:02
  • The machine output 2 dump has a lot of non-IP traffic (LLC mainly) which starts as soon as the first tcp connect is attempted. I would consider this 'suspect'. Is the wireless access-point reporting any problem? – Koos van den Hout Jan 13 '11 at 10:17

Looking at your traces, the two machines are trying to connect to two different endpoints. It looks like you are trying to connect to test.org.uk:

Machine 1

  • IP address:
  • DNS server used:
  • Answer: www.test.org.uk = test.org.uk =

Connection results: successful transaction (with a 301 Moved result)

Machine 2

  • IP address:
  • DNS server used:
  • Answer: test.org.uk =

Connection results: the SYN request is ignored; no TCP connection is made


I'd say try connecting to these servers using their IP numbers instead of their DNS names.

By the way, I'm not sure that the other non-TCP traffic would be relevant...

My guess as to the culprit? The test server test.org.uk combined with the NAT gateway: test.org.uk might just be recognizing both machines as coming from the same source (the NAT gateway). But that doesn't solve the problem posed originally - if your problems go beyond just test.org.uk. Try another site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.