I have a Windows 7 Laptop Workstation with a Ubuntu 10.10 VM running in Virtual Box 3.2.12 r68302. I recently updated Samba and winbind, and since the update, I am unable to access the machine via it's hostname (\mystique) from the VM Host. I can access it by the "Host-only" IP (\ and the DHCP Assigned IP address (\ and I can connect to the webserver on the machine via it's hostname (http://mystique/).

As stated, accessing this machine via it's hostname worked fine prior to the update, but has since stopped working. I have added the hostname to the smb.conf for the netbios name, to no avail.

My smb.conf [global] section looks like this:

   workgroup = NETWORK
   netbios name = Mystique
   server string = %h server (Samba, Ubuntu)
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d

   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
   usershare allow guests = yes

EDIT: I have also tried creating an entry in c:\windows\system32\drivers\etc\hosts for mystique but that doesn't work either

EDIT 2: When I boot the machine at home, with no other changes, I am able to access the VM Guest by hostname without any issues. This leads me to believe the problem has something to do with the DHCP system at the office ...

1 Answer 1


Turns out it was the DNS settings of the VM Host OS that needed to be changed. Once I set them to the Domain Server in the office, everything works. Not sure how this will impact DNS at home yet, but it solves my initial issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .