Running a CITRIX presentation server farm, version 4.5.6 on Windows 2003 sp2.

In the CITRIX Access Management Console, I sometimes get a session that shows it's in a down state - but has none of the normal info associated with it (user name, applications, client name, idle time, etc...).

It does say which servers it's on, so I check out that server's terminal services manager. I can see the down session but cannot reset it. I get:

(Error 7024 - the requested operation cannot be completed because the terminal connection is currently busy processing a connect, disconnect, reset, or delete operation.)

So I go to the task manager and look up the processes running under that session id. I see it's one of my published apps, but when I try to end the process - it simply does nothing and the process remains.

Any way to get rid of these sessions without a server reboot?

5 Answers 5


Connect to the offending server (RDP or psexec to the command line) and do a qwinsta. It will show you the down listener (usually it will be session 6553x). Note that number, then run rwinsta 6553x with 6553x being the number of the down listener.

  • interesting, thanks. This isn't the command the GUI runs when you highlight the down session, right+click and choose reset?
    – Chad
    Jan 26, 2011 at 23:10
  • I don't believe so because the GUI fails when you try to reset a listener.
    – user65237
    Mar 18, 2011 at 15:01

I've been working with this problem for some time and yesterday was the first success. I downloaded the portable app version of Daphne. Once it was copied to the server, I used qwinsta to find the session id of the down user. I then used tasklist to see the PID's of the down user. Then using Daphne, I started killing the processes by PID associated with the down user. I tried to kill the processes for the session id of the user that were owned by administrator, like winlogon.exe, but they just came back in a few seconds. But, if you kill the processes owned by the down user, in this case winword.exe and another published app, Daphne was able to kill the process and Windows server 2003 closed the rest. The down session went away, and the access management console went back to normal activity.


I had this problem too that was occurring too often, when this problem happens i can't even kill the user's process with process explorer so what's the difference when using Daphne?

On another note, the way to troubleshoot this issue is by checking the following:

  • is it a streamed or published application? (if streamed you can check with the latest offline plugin)
  • what are the processes involved? are they the same processes? you can then look for Microsoft KBs involving the process for your terminal server version
  • check if this problem is a fixed issue in the latest Citrix rollup pack

You're right. I experienced the same thing with process explorer, and I don't know why Daphne works. Process explorer would lock almost every time I touched the processes of the down users. I've been trying as many different things as I could for quite some time, and Daphne worked the first time I tried. I checked for the down session ID, looked for the published app run under the down session, and asked Daphne to kill that process. The session was closed orderly, the down session was gone, and the server didn't need rebooted.


Impact: The csrss.exe process might show high CPU consumption because of vtdw30.dll being unable to free enough memory. [From PSE450R03W2K3030][#193786]

Resolution: https://support.citrix.com/article/CTX123772

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .