I manage simple workgroup at work that uses openvpn gui for connecting to remote computers.

Accidently I discovered a very strange bug -- the openvpn connection works initially, and pings work, but after 30 seconds, pings and any other access stop working, without any discernable reason.

Openvpn client shows as still connected (no new logs, the icon is green), the openvpn server shows that the connection is still established (but cant ping the client either), windows logs doesn't show any clue. And from home i still connect through the VPN without problem.

I need clue for where to look on, any other logs or tests?


womble suggested to check route table, simple script shows that there is no change in route table :(, thank you anyway womble.

8 Answers 8


Oh number one cause of this in our company is the same OpenVPN key being used simultaneously in two different places. The same IP gets allocated by the server to both clients, causing a dropout after a minute or two.


That smells like a client-side routing problem. Take a look at the routing table immediately after the OpenVPN tunnel establishes (while it's working), and then again after it stops working, and look for any differences. I've had a problem where a DHCP client was wiping out (overriding) routes from OpenVPN, which would make the connection to the OpenVPN server unavailable.

  • thankyou. i am checked the route table table by script. my script doesn't show any changes after connection. and doesn't show any changes after that connection fail
    – Avram
    May 1, 2009 at 12:52

Can you post the openvpn config files? If so, be sure to conceal any private information like IP addresses or domain names.


See if you can ping the gateway host on its internal ip address. Also run a traceroute and see where those packets are going.


I was experiencing this exact same issue, with the connection working fine for a few seconds and then stalling without any information in the logs. Starting OpenVPN with --mssfix 1300 fixed the problem on my system.

From openvpn(8):

Both --fragment and --mssfix are designed to work around cases where Path MTU discovery is broken on the network path between OpenVPN peers.

The usual symptom of such a breakdown is an OpenVPN connection which successfully starts, but then stalls during active usage.


I faced the same problem using Ubuntu. I did some steps and it worked for me. (I don't know if this is the best way to solve this problem, it's just what worked for me)

Remove OpenVPN:

sudo apt-get remove openvpn

Back up the directory /etc/openvpn to ~/Documents or any other preferred directory (I restarted my computer after that)

sudo mv -b /etc/openvpn ~/Documents

Install OpenVPN again

sudo apt-get install openvpn

Copy the file update-resolv-conf to /etc/openvpn

sudo cp ~/Documents/openvpn/update-resolv-conf /etc/openvpn

I don't know if this solution will help you but I hope I have helped in some way.


Most routers or cellular operation are using NAT with very short timeouts for UDP sessions. Solution is to reconfigure router or force OpenVPN to send ping packets more frequently (check keepalive config directive)


The problem was on router, after reconfigure router, the vpn start to work again.

  • 3
    what was the fix?
    – gregmac
    Aug 14, 2009 at 4:10
  • @gregmac reconfiguring the router.
    – Avram
    Oct 30, 2009 at 0:41
  • 6
    Would be nice to know what was reconfigured. Not helpful!
    – Alfabravo
    May 9, 2011 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .