Hey, I have a strange problem with my exim4 configuration. I have a dedicated server running debian for quite a long time now, but I'm not really using it actively recently, so everything just worked due to lack of changes ;)

However, recently, my exim4 smtp stopped answering on port 25. It does not respond through localhost, as well - even though it's set to listen on any interface available.

Some things I've checked:

  • ks:/home/trakos/Maildir/new# netstat -ap | grep exim
    tcp 0 0 *:smtp : LISTEN 12521/exim4

  • ks:/home/trakos/Maildir/new# exiwhat

  • 12521 daemon: -q30s, listening for SMTP on port 25 (IPv4)

  • ks:/home/trakos/Maildir/new# cat /var/log/exim4/rejectlog

  • ks:/home/trakos/Maildir/new# cat /var/log/exim4/paniclog

The queue is set for 30s only because I was running it in a non-daemon mode to see any output. Strangely enough, no suspicious output is given, netstat even shows it is listening on port 25, but still trying to telnet to it times out.

The only things that may have changed recently are:

  • I've got second IP for my server

  • I remember that few days ago my spamassasin crashed, and I've started it up again

So yeah, I'm really clueless about this one now :P I mean, I don't even know what could be failing here. Could someone give me some ideas what should I check next?

PS: it has uptime of 442 days, so I haven't really tried rebooting it yet ^^

| improve this question | | | | |

You have tried restarting exim? "sudo service exim4 restart" should do it, or "sudo invoke-rc.d exim4 restart" depending on release (not sure when "service" was added, am running unstable everywhere)

Though before that... have you tried sending mail on localhost and looked if it arrives? Have you checked /var/log/exim/mainlog? Done these two together, as in, send mail and then check mainlog if something shows up?

Oh, and you haven't told us how you tested this "stopped answering on port 25" and what the error was. What does exim say in mainlog when you try telnetting to port 25 (which I presume you've tried)?

| improve this answer | | | | |
  • Thanks! Yeah, I've did restarted exim4, mainlog seems to be ok - I mean, only queue information there. I obviously can't send mail from any client and even no output is put in logs, but sending locally through sendmail to the local recipient worked. Telnets timeouts, just hangs on 'Trying' for quite a long time, and then prints 'Unable to connect to remote host: Connection timed out' – trakos Jan 15 '11 at 16:58
  • Then I'd check firewalling and/or tcp wrappers, since exim is listening on 25. Hmmm, maybe try an nmap onto localhost first. And there's nothing in and exim log for that timed-out telnet attempt? That smells like (accidential) firewalling. – Jürgen A. Erhard Jan 15 '11 at 17:06
  • damn, you're right, nmap told me it was filtered, and it appeared to be just dropped through iptables. I have no idea why. It's hosted @ ovh, could they have just iptabled it for me? I don't really recall using iptables at all... – trakos Jan 15 '11 at 17:27
  • Do you have any firewall SW installed? Since, if I've interpreted the "dedicated" right, you have full control, I don't know why ovh should have a firewall installed. Of course, they might, but I'd be majorly beeped if my hoster firewalled for me without telling me. Check on your plan/contract with them, if you don't find a FW package installed. – Jürgen A. Erhard Jan 15 '11 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.