1

hI, I am trying to install the terminal multiplexer tmux on my Debian Lenny server so that I can have multiple terminals through ssh.

However I have had a lot of difficulty installing it from the debian package, and by compiling it. When I try the package it says something about the wrong version of libc6, and when I compile it I get the following error:

server.o: In function `server_start':
server.c:(.text+0x273): undefined reference to `event_reinit'
collect2: ld returned 1 exit status
make: *** [tmux] Error 1

Help would be very much appreciated, RayQuang

0

Your packages may be a little different, but on Ubuntu I had to:

sudo apt-get install libevent-1.4-2 libevent-dev libncurses5-dev
0

See also: https://superuser.com/questions/219095/tmux-compilation-error-in-andlinux-ubuntu

Quoting the answer from there:

I just found out that libevent-dev that comes in ubuntu repository wasn't new enough. It worked fine after I installed the latest version of libevent from source. Remember to remove the libevent-dev if you've already installed it via apt-get.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.