I have a windows server 2008 R2 standard edition. The system suddenly stopped accepting remote desktop connections. When I tried to connect directly to the console, I am unable to start any applications. I got errors "The page file is to small to complete the action". Under takmanager in performance the system shows "Commit(GB) 127/127". What does this imply?

The system has 32 GB ram, 5 raid disks each 150 Gb


It doesn't imply anything - it's telling you that the page file is too small for the current usage of the system. How is the pagefile configured? And what are you running? FYI - A tool like Process Explorer from Sysinternals is even better than Task Manager for stuff like this.

OK - if you can't do anything from the console, and can't run any management tools remotely from another machine, reboot your server and then post what the pagefile settings are.

  • 1
    It could also be that the C: drive is out of space. I'd look for that. – user3914 Jan 16 '11 at 19:35
  • 2
    @mfinni - I believe the op is stating they CAN'T get that info because they can't run any apps besides task manager – Mark Henderson Jan 16 '11 at 19:35
  • 1
    @mfinni - Maybe he is, but as he's only logged in remotely with Task Manager, he's unable to tell. – user3914 Jan 16 '11 at 19:37
  • 1
    @Mark - well, at this point, kishore should reboot the server and then remediate any configuration problems. – mfinni Jan 16 '11 at 19:38
  • 1
    @kishore - go to the server and hit the power button. Power saving should recognise that as a shutdown command, and the box should shut down. Then you can restart it and see what went wrong from the Event Viewer. – user3914 Jan 16 '11 at 19:44

Update: In task manager insert all the memory counters in the process tab. Also look in the resource monitor(opened from the performance tab). Also use process explorer. There is something eating your page file. Maybe some process is using page file to store information ( like process monitor does). Close processes that are not needed.

Before update: Some process is probably leaking memory badly. In the process tab of task manager add the "memory- commit size" and check which process is the offender.

  • Only sql server process has 3.3 GB of commit size. Others are below 100mb. But the server has a RAM of 32 GB out of which only 20% is being used. – kishore Jan 16 '11 at 21:26
  • @kishore - do you still see the Commit(GB) 127/127 in the taskmanager? – Igal Serban Jan 16 '11 at 21:37
  • Yes. It is still showing 127/127 – kishore Jan 16 '11 at 21:41
  • @lgal Serban, I tried to open resource monitor, but it errored out. I cant open any application other than taskmanager. – kishore Jan 16 '11 at 22:30

I have rebooted the server. I found that the problem is being caused by fdhost.exe service (Full text search). Maximum memory limit was not set on my sql server so it claims all the available RAM and fdhost.exe service then starts paging. After reboot within 20 minutes the page file grew to 127 GB again. I have configured the maximum page file size to 48 GB recommend by MS(1.5 times of RAM), then configured the maximum memory setting on SQL server.

I have also installed this hotfix for Windows Server 2008 R2 http://support.microsoft.com/default.aspx?scid=kb;EN-US;981314

This fixed the problem. This is the article that says about full text search and its paging problems http://technet.microsoft.com/en-us/library/ms142560.aspx.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.