The hard disk on our server reached maximum capacity 5 days ago. SVN did not seem to be effected, and the dev team carried on as if nothing happened. It's only now we have started getting problems trying to commit changes.

Can't move '/repos/db/txn-protorevs/1000-vr.rev' to '/repos/db/revs/1/1001': Permission denied

It's not a Permissions problem. The file it's looking for does not exist.

I have tried svnadmin verify and recover but nether seem to do anything.

I do have a backup. If I go back 5 days, how do we resync the clients (i.e commit all that has changed).

We are using TortoiseSVN and ankhsvn for VS.


It is a permissions problem. It's not a permissions problem with the non-existing file, but with the directory the file is being moved from or to.

| improve this answer | |
  • I have tried logging in as the SVN user, and creating a file in that directory. No problems, so why would the client try to move a file that does not exist? – user37914 Jan 18 '11 at 20:10
  • Which directory? /repos/db/txn-protorevs/ and /repos/db/revs/1/ and two seperate directories. I suspect the permissions on txn-protorevs don't allow the svn user to create/move/delete files. – Alex Holst Jan 18 '11 at 21:55
  • Your right, I tried it again, and writing to the output directory failed. Doh, could have sworn I tried that several times. Thanks. – user37914 Jan 18 '11 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.