I have installed, configured DNS server(local instance of Dnsmasq) which resolves to localhost as I want, all OK.

When I go offline, it stops working, because OS X empty content of resolv.conf and ignore attempt to reflect changes in this file.

Any idea, how to configure DNS even when offline?

Similar issue(unresolved): http://blog.steamshift.com/geek/leopard-lookupd-and-local-web-development-sites

Main motivation is ease development of RoR application which uses subdomains as account keys. And you can not use *.yourapp.local in /etc/hosts. Some guy registered domain smackaho.st and srt DNS for it like .smackaho.st at but still, you can not use it when you are working offline.

EDIT: tried scutil command, but it seems you can change DNS if offline

NOTE: when you have all interfaces down, you cannot set DNS servers in Pref. panel.


6 Answers 6



I also enjoy using Dnsmasq on my local machine, and I had this problem too. Here is the solution:

From man 5 resolver:

The configuration for a particular client may be read from a file
having the format described in this man page. These are at present
located by the system in the /etc/resolv.conf file and in the files
found in the /etc/resolver directory.

/etc/resolver/ is not present by default; you must create it yourself.

Also from the man page:

  Domain name associated with this resolver configuration. This
  option is normally not required by the Mac OS X DNS search system
  when the resolver configuration is read from a file in the
  /etc/resolver directory. In that case the file name is used as the
  domain name.

So if you wanted all dns queries for the top level domain of dev to be routed to the local nameserver, you would:

# mkdir /etc/resolver
# echo 'nameserver' > /etc/resolver/dev

configd does not alter files in /etc/resolver/, so this setting will persist through network changes and reboots.

UPDATE 17 July 2012

Unfortunately, as of OS X Lion, the top resolver (as shown by scutil --dns) disappears when no interfaces are active:

# scutil --dns # Online
DNS configuration

resolver #1
  nameserver[0] :


resolver #8
  domain   : dev
  nameserver[0] :

# scutil --dns # Offline
DNS configuration

resolver #1


resolver #8
  domain   : dev
  nameserver[0] :

Notice that resolver #1 is empty, but that the /etc/resolver derived nameserver entry remains.

It turns out that since you can specify the resolver domain directly in the /etc/resolver/ file, specifying the special Internet root domain . causes the creation of a global resolver entry that looks like:

resolver #8
  nameserver[0] :

Now all DNS queries are routed to localhost, even when offline.

Of course, you will still have to resolve your chosen domains as using something like dnsmasq's --address option:

# dnsmasq --address=/dev/

In summary:

  • Set all your network interface dns servers to
    networksetup -setdnsservers Ethernet
    networksetup -setdnsservers Wi-Fi
  • Create a file /etc/resolver/whatever:
    domain .
  • Set up a local DNS server and be happy.

cf. http://opensource.apple.com/source/configd/configd-395.11/dnsinfo/dnsinfo_flatfile.c

  • 1
    That is exactly what pow is using (pow.cx).
    – daeltar
    Sep 5, 2011 at 9:00
  • but unfortunately it does not work - github.com/37signals/pow/issues/104
    – daeltar
    Mar 14, 2012 at 12:54
  • 4
    @guns does this solution still work in yosemite? dnsmasq was working fine for me offline until I upgraded. Now all I get when I run scutil --dns when not connected to the internet all I get is No DNS configuration available I followed your instructions above but no luck
    – MatthewLee
    Oct 23, 2014 at 17:36
  • 2
    @MatthewLee, yes you are right, it seems the only work around is adding entries in the hosts file.
    – Lenciel
    Dec 31, 2014 at 3:17
  • 2
    Anyone found a solution for Yosemite yet?
    – jmagnusson
    Apr 3, 2015 at 12:37

Why not make the entries in /etc/hosts instead? I'm having trouble thinking of a situation where you'd need to actually be running a full blown DNS server. I use host file entries all the time to accomplish things like this on my Macs.

The resolver in OS X works differently than that in Linux or other Unixes. This is probably part of what's causing you grief. Like for instance it has a preferences for which method of resolution to use first and it caches the results of all queries for a period of time.

Have you added the DNS server to the interface in the Network preference pane? This should ensure that the resolver uses that server for it's queries should it decide to look for a DNS entry.

  • One reason to use a DNS forwarder on a client machine is to maintain a large blacklist of ad/malware domains without suffering the performance penalty of the resolver daemon grepping the now bloated hosts file on every request. The merits of this approach notwithstanding, dnsmasq loads /etc/hosts into memory where the lookup time will be miniscule. Also, if you do web development, it allows you to avoid the small nuisance of adding local domains for every site you are working on.
    – guns
    Jul 26, 2010 at 20:45

(answering b/c I can't comment yet...)

How are you going offline?

(best answer I got right now)

# man -S 5 resolver
 Note that the /etc/resolv.conf file,
 which contains configuration for the default (or "primary") DNS resolver
 client, is maintained automatically by Mac OS X and should not be edited manu-
 ally.  Changes to the DNS configuration should be made by using the Network
 Preferences panel.

So, you should be able to enter something in the UI, and it should stick. I had done this a couple times when I had not like the DNS server my local DHCP server provides.

  • Changing the DNS-configuration in NetworkPreferences changes the /etc/resolv.conf file. Jun 23, 2012 at 12:45

Does OSX have the /etc/dhcp3/dhclient.conf configuration file that normal Linux/UNIX DHCP client configurations have?

If so, it should have a line you can uncomment for

prepend domain-name-servers;

to have the DHCP client always add that line to your resolv.conf

  • Adding to resolv.conf is not helping on OS X. Content of resolv.conf is generated and itself is symlink on /var/run/resolv.conf and even when I change /var/run/resolv.conf it does not reflect changes.
    – daeltar
    Jun 10, 2009 at 9:34

Try adding a second ethernet service configured with a static address and as your DNS server. Or, add a network Location which sets your DNS server to Both of these changes would be made in "System Preferences" under the "Network" panel.


It might help to just put       localhost

into /etc/hosts, so it doesn't need to resolver to find localhost.

  • 1
    I need it for subdomains, so this is no no.
    – daeltar
    Jun 10, 2009 at 9:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .