We have subdomain entries in our local DNS server which we use for web development. The IP's they point to our bound to web sites.

For Example:
FarmA.webstaging =
FarmB.webstaging =

The domain name entries have been setup for many years now and work fine with XP and Server 2003 systems.

Now that we are rolling Windows 7 into our environment we are having issues with these entries. You cannot browse or ping the names, but if I use nslookup I do receive the correct IP address.

When you ping the FQDN (e.g. FarmA.webstaging.ourdomain.com) the name resolves as expected. Checking the DHCP information I received I have a primary DNS Suffix of ourdomain.com and ourdomain.com is listed in DNS suffix search list. So I should not need to include the domain name.

If I add entries into the hosts file, I am able to browse and ping the name, it resolves correctly.

What I would like to find out is why this is happening and if there is a way to correct this issue without having to add hosts file entries to each windows 7 machine. (I have not tried Windows Server 2008 yet).

Update: What I have noticed is that the name will resolve using nslookup.

nslookup FarmA.webstaging 

works fine in resolving the ip address; ping cannot resolve.
I have noticed in the past that ping and nslookup seem to resolve addresses differently, something I have not been able to discover why.


I ran into this problem. Unfortunately, the solution isn't as obvious as fixing the DNS suffix!

See this article for a complete explanation and the solution: http://blogs.technet.com/b/networking/archive/2009/04/16/dns-client-name-resolution-behavior-in-windows-vista-vs-windows-xp.aspx


Windows 7 has a rule change compared to Windows XP when it comes to how the DNS resolver treats multi-level names: By default, Win7 will NOT append your DNS suffix to multi-level names, whereas Win XP did. This means that in Win7, FarmA.webstaging will not work, but webstaging by itself will work, as will FarmA.webstaging.yourcompany.com (i.e. the FQDN).

To fix: open up group policy editor and browse to:

Computer Configuration -> Administrative Templates -> Network -> DNS Client -> “Allow DNS Suffix Appending to Unqualified Multi-Label Name Queries”

Set this to "Enabled" and restart your browser; it should fix the problem.

| improve this answer | |
  • Just to chime in, this is also good for Server 2008 R2 (64 bit). We were having an issue with a newly built Web Server. In Server 2003, we could ping the site website without any issues. In Windows 2008 we could only ping the site if we tried "ping website.company.local". By making the policy change as outlined in this article on the Server it worked as in previous versions. Thanks to John Evans, great answer. – user188895 Sep 6 '13 at 14:55
  • I had this happen to me yesterday on Windows 7. Local DNS has been working perfectly until I did a Windows update. Threw me off a bit that the network bridge I have seemed to start acting up at the same time. After I did what's suggested in the answer everything works smoothly again. – h00ligan Mar 22 '14 at 10:23

You say:

When you ping the FQDN (e.g. FarmA.webstaging.ourdomain.com)


ourdomain.com is listed in DNS suffix search list. So I should not need to include the domain name.

This would be true if webstaging.ourdomain.com was in the search suffix list. It's not, so this is behaving as expected. You'll have to add webstaging.ourdomain.com to the search suffix list either manually or through DHCP options to get the behavior that you desire.

| improve this answer | |
  • Granted webstaging.ourdomain.com is not in the search suffix. This configuration works fine on XP and Windows 2003 Server machines. So I am assuming there have been changes made to the Win7 and 2008 IP stacks updating this behavior? – Brettski Nov 14 '11 at 14:39

did you check ipconfig /all? What is the "node type" of the Windows IP Configuration?
If its Node Type . . . . . . . . . . . . : Peer-Peer then follow these steps:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry

  3. In the right pane of Registry Editor, delete the following values if they are present:

    - NodeType
    - DhcpNodeType 

    If the NodeType value is present, this value will override the DhcpNodeType value. If neither subkey is present and if no WINS servers are configured for the client, the computer uses b-node mode. If at least one WINS server is configured, the computer uses h-node mode.

  4. Quit Registry Editor

  5. Restart the computer
  6. Try ping computers by their names

An "ipconfig /all" should now give:
Node Type . . . . . . . . . . . . : Hybrid

| improve this answer | |
  • Node type is already set to "Hybrid" – Brettski Jan 20 '11 at 15:28
  • ok. it was a wild guess ;) – Luke99 Jan 20 '11 at 20:34

That was a good one:) Make sure that on your windows 7 box you have on your network connection (Local Area Network or whatever)->ipv4->advance TCP/IP settings->DNS you have check "Append this DNS suffixes (in order)" and that ourdomain.com is in that box.

Even if DHCP gives you an address it does not mean that it registers it in DNS also. You need to allow dynamic updates

Its complicated to explain why, but its the way MS implements DNS for resolution of unqualified names. You may want also to check "register this connection in DNS"

See if it works.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.