I am running WinServer 2008 and am trying to RDC into other machines within the network. I am able to ping the machine and trying to connect via RDC does bring up the Remote authentication dialog for ID/PW (title of the dialog is 'Windows Security'). However, when I enter the ID/PW, it fails and gives the message 'Your credentials did not work'.

I am able to connect to the machine via a logmein type of remote support tool and can see that the ID and PW will log in to the machine.

Any ideas as to why RDC is not authenticating in this situation would be appreciated.


Well, there are a whole lot of variables you want to address. Sam asked some important ones. If you are using LogMeIn, you will not have the RDP port open or the RDP service active, and your user will not necessarily be in the appropriate group. If you do not see you username on the Windows 7 box in the output of either command once you paste them into the Command Prompt, you will obviously not be able to RDP into your Windows 7 box.

net localgroup administrators

net localgroup "remote desktop users"

Another question: Are you connected to an Active Directory domain? When you open a RDP session, select Use Another Account. You will notice that under password is a line that says DOMAIN:. What is after that is important. Are you trying to connect with domain credentials? If so, that means the domain should be mentioned there. If not, you need to make sure you a specific about which credentials. So, if you are using local credentials (I mean local to the remote computer you want to RDP into, not the Win 2k8 server), you need to specify your want to authenticate against that. So for username, put in HOSTNAMEOFWIN7BOX\yourusername here. This should not be a problem but was for me at one time (I cannot remember if it was NT 6.* to NT 5.* boxes or vice versa).

  • Yes, I see that the ID is listed in both groups. Here is something I see... if I use the machine name, I get an error that says "This computer can't connect to the remote computer."..etc. If I RDC to the IP, then the login screen comes up and even though I enter the correct ID/PW, it will not connect. – Russ Jan 19 '11 at 23:10
  • We are not on a Domain and the domain field is blank. I tried 'Use Another Account' as you suggested and entered <machine name>\<userid> in the username field and I got the same result. That was a good idea though. – Russ Jan 19 '11 at 23:37
  • @Russ you are doing this all with the firewall off, yes? If so, there is something strange going on with your computer. Again, I have two important questions I want to reiterate, reading your responses. 1) Are you sure there is no other AV with a firewall installed (this gets me every time and I do this for a living)? 2) Is RDP enabled (HINT: wmic /node:"computername" /user: "domainname\username" /password:"password" rdtoggle where servername="computername" call SetAllowTSConnections)? 3) Now, have you tried this account locally without RDP to esnure the password is correct/not expired? – songei2f Jan 20 '11 at 14:08
  • alharaka, thank you again for your reply. Much appreciated. Alright, I have egg on my face here. I realized this morning that the ID we use on the local system to login is showing a friendly name like "Susan", but not the profile name which is something like "Acme Employee" and it was the "Acme Employee" that needed to be entered in the RDC connection..and not "Susan" which is shown on her login screen. Thank you very much for your insightful guidance! – Russ Jan 20 '11 at 15:52
  • Glad to help. I make silly mistakes like these all the time. Believe me, it is only more annoying once you discover the root cause is PEBKAC. – songei2f Jan 20 '11 at 16:51

Does the user account you are using have the correct rights to RDP to theses machines? Is RDP even enabled (although I suspect it is if you are getting as far as entering credentials).

  • Yes, RDP is enabled on both the server and the target machine. Although, in this situation, I am trying to RDC from the server to the Win7 target. A login screen is actually coming up, but the ID/PW is not being accepted via RDC where it is being accepted locally on the machine. I hope that helps clarify a bit. – Russ Jan 19 '11 at 21:45
  • Ok, so the user account is valid to logon locally, but is it a member or local admin or remote desktop users group on the machine? – Sam Cogan Jan 19 '11 at 21:53
  • Yes, the user is in the administrators group. The ID was not in the remote desktop group, so I added it there too and still can't RDC to the Win7 machine. – Russ Jan 19 '11 at 23:07
  • I just tried turning the firewall off for home/work and also for public and then I can ping the ip address, but still not the computer name. – Russ Jan 19 '11 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.