I have a Windows 2008 server (Standard, with SP2).

Windows Firewall is OFF

File sharing is ON

Password protected file sharing is ON

I am unable to access my C: drive share either from the local console or from a remote machine.

This is what happens when I log in from the local console:

If I click Start -> Run and enter \MyMachineName and press enter, an Explorer window opens showing my share "C" and "Printers".

If I double click on "C", I get a message saying "Windows cannot access \MyMachineName\C". If I click the "Diagnose" button, it says ""MyMachineName" is not set up to establish a connection on port "File and Printer Sharing (SMB)" with this computer.

Any ideas how to solve this?


I'm not sure if that's a typo up there, but have you tried \\servername\c ?

Also, try \\servername\c$ and supply creds and see if you can access the admin share.


I know that you said:

File sharing is ON

However, let's just make sure that what you are seeing telling you that file sharing is turned on is what I assume you are looking at. Go into your network connections (run >> ncpa.cpl). Right click each of your active TCP/IP adapters and click "properties". Is "File and Printer Sharing for Microsoft Networks" enabled? Is "Client for Microsoft Networks" enabled?

From within the Network Connections window, tap the 'alt' key and select the "Advanced" dropdown menu. Choose "Advanced Settings...". In the "Connections" window, select each of your main adapters in the "Connections" area and then make sure that all of your bindings are enabled, specifically "File and Printer Sharing for Microsoft Networks:

alt text

  • Yes, I see the bindings that you're mentioning. All network adapters have File and Printer sharing for Microsoft Windows and Client for Microsoft Windows enabled. – Bryan Slatner Jan 22 '11 at 3:45

Check on the MyMachineName, if C is shared with the option 'SMB' checked. You see this option on the share permissions tab on properties of C.

  • I don't see this "SMB" option on the share permissions. All that's on there is users and groups. – Bryan Slatner Jan 22 '11 at 3:43

I'm sorry, but the reason this isn't working is because the C drive, the root of any drive is: a) Not actually able to be shared, because b) It is already shared.

The root of every drive has an "Administrative Share" already made.

The way you can access it is by typing in (without quotes): "\servername\c$"

You'll have to authenticate, but you'll be able to access the whole drive.

  • FYI, you can share the root of drive. In fact you can share the same path many times over with different "share" names if you like, all to the same place with different "share" permissions. – SpacemanSpiff Jan 20 '11 at 23:13
  • I was kinda under the impression that it wouldn't allow you to create shares of the root, simply because they already existed administratively, $.EDIT: I just tried it, and yea it does let you. My bad. I know you used to not be able to. – JohnThePro Jan 20 '11 at 23:20
  • SpacemanSpiff speaks the truth. – Wesley Jan 20 '11 at 23:24
  • Drive-by Anger! – JohnThePro Jan 20 '11 at 23:31
  • @JohnThePro Not anger, just using ServerFault as it was meant to be used. I was the one who downvoted you. A downvote isn't a personal attack necessarily, although I think some people use it that way. It's just a way of signifying to present and future viewers "Hey, this answer isn't quite right". At least, that's how I use downvotes. – Wesley Jan 20 '11 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.