I've set up a fileshare that I want my users to be able to read/write/delete to. The problem is that I'm able to list content and delete it, not read/write. Yes, this goes for several users.

The permissions look like this:


No inheritance from parent folder.
Owner: Administrators
Full control: Authenticated users, Administrators


Full control: Authenticated users, Administrators

I bet I missed something trivial. Could someone point me into the right direction?

Update: Now I only lack read/execute permissions after adding system, the group Users and creator owner to NTFS permissions settings (gave them full control).

It struck me that perhaps the problems is caused by some linux permissions? I copied all files from a linux smb share so the files still have linux perissions i guess, could that be it?

If so, how do I remove those?

3 Answers 3


If you are on a Domain, you might have better luck with the Domain Users group. Also, Windows will apply the most restrictive of the combined share and NTFS permissions, so you could also try granting Everyone full control on the share, and because the NTFS permissions are more restrictive they will take precedence.

  • Thanks for the tip. Yes, I'm in a domain (2008 level if it matters) and did try what you said. NTFS: No inheritage. Owner: Administrators Full control: Administrators, Domain users Share: Full control: Everyone Its still the same tho, cant read or write. Any onther thoughts?
    – xeet
    Jan 22, 2011 at 19:48

Check if you have the user right "Bypass Traverse Checking" disabled. A quick way to check this is to logon to the server where the share is located, and run gpedit.msc > Windows Settings > Security Settings > Local Policies > User Rights Assignment. This right is granted to Everyone by default.

If it were disabled, users would also need to have access to any parent folders of the share.

For more information:

Client, service, and program incompatibilities that may occur when you modify security settings and user rights assignments

  • Thanks for answering. So if I get this right, if I enable this setting (by selecting one or more groups/users) I might be able to get it to work? I newly added a home directory share in the same parent folder as the one I've a problem with and that one is working just fine for some reason? Could that setting still help?
    – xeet
    Jan 23, 2011 at 18:36

This turned out to be an issue with the encryption windows applies. Removing the encryption solved the whole thing:/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .