1

I was installing memcache on my Cent OS 5 server and I am following this guide > http://www.howtoforge.com/php_memcache_centos5.0

And now, when I enter, phpize && ./configure --enable-memcache && make

the server says phpize: command not found

So, I tried this command yum -y install php-devel and following is the answer from the server

Loaded plugins: fastestmirror
Repository 'vz-base' is missing name in configuration, using id
Repository 'vz-updates' is missing name in configuration, using id
Loading mirror speeds from cached hostfile
 * addons: mirror.5ninesolutions.com
 * base: mirror.san.fastserv.com
 * extras: mirror.nwresd.org
 * rpmforge: apt.sw.be
 * updates: mirror.5ninesolutions.com
Excluding Packages in global exclude list
Finished
Setting up Install Process
No package php-devel available.
Nothing to do

So... any clue?

2 Answers 2

2

Where did you install php-devel to? The default directory? It seems that phpize either isn't installed or itsn't not in your path. Can you run a find for phpize? Once located, you can either add this to you path, or call it directly.

2
  • type whereis phpize and it should locate it. Then execute it from the full path. let's say /usr/bin/phpize for the sake of this example.
    – egorgry
    Commented Jan 23, 2011 at 19:54
  • I used this /usr/local/bin/phpize && ./configure --enable-memcache --with-php-config=/usr/local/bin/php-config && make and it has been installed well. Thanks for both of you :D
    – Prasad N
    Commented Jan 24, 2011 at 13:29
2

Add jasonlitka repository

Install php-devel:

yum -y install php-devel
2
  • I've just updated the question with the result...
    – Prasad N
    Commented Jan 23, 2011 at 17:25
  • still no any success :(
    – Prasad N
    Commented Jan 23, 2011 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .