Ok so here's the setup:

I have pdns w/mysql backend set as a master only. the internal net includes the dns server address so things do resolve there. But externally the domains do no get resolved at all, unless you specify either the secondary or master server in the query. I've verified with opendns, google public dns, and comcast dns cache all cannot find the domain. Even the big paid us now registrars are saying its available. I have also talked to zerigo's tech support and they are saying that I need to register my domain with godaddy, which will not do since I have owned this domain from 2003 onward and they tried stealing it from me five times now.

So how can I get the domains on my master server and off-sited secondaries to get resolved by the rest of the world?

  • If I'm reading this right, your domain is not resolveable from anything but your specific DNS server, and you'd like to fix that? – sysadmin1138 Jan 23 '11 at 20:32
  • What's the domain name, Dwight? We can figure out what's going on if we can look up the domain name. – Avleen Jan 23 '11 at 23:49
  • You should remove the domain name from your comment because it appears to be unregistered, and you run the risk of somebody else registering it under their name. – Nic Jan 27 '11 at 2:51
  • thanks @Nic I didn't think of that. Comment removed. – Dwight Spencer Feb 1 '11 at 21:50

You didn't mention which operating system you're using, but since you have pdns I'll just assume it's something *nix based. What results do you get with these commands?

$ whois mydomain.com

The WHOIS registry will tell you which nameservers are listed as being authoritative for your domain name. This should match what you've configured with your registrar. Look for a line called "Nameserver".

$ dig mydomain.com ns

If you do a DNS lookup for the nameserver, you should get exactly the same results that WHOIS produced. If the answer is blank, or does not match the WHOIS result, then you've found the problem.

|improve this answer|||||
  • You are right is a linux cluster. The whois registry is empty and dig only works for my primary's and secondary servers. From what I can tell the domains are not being propagated to the root domain servers. – Dwight Spencer Jan 26 '11 at 20:54
  • Your domain is not being propagated to the root servers because it is not actually registered. You need to re-register the domain with your preferred registrar. – Nic Jan 27 '11 at 2:49
  • This wasn't a problem when I ran BIND9 and mirrored internic. Stupid question, but is there anyway to set that up in PDNS? – Dwight Spencer Feb 1 '11 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.