The SAS Controller Card in a production server of ours went bad. This was an older server, and Dell does not have the card in stock and not ETA for one. So, I ordered one from NewEgg.

I installed the card, and it's working, somewhat. It's at least reading the drives enough to show me the RHEL splash screen, but it fails to boot, with errors that it can't find /proc, etc. I expected errors since I'm pretty sure there's some data corruption. These were in RAID1.

Anyways, new card works enough - I can get the drives turned on and hear them spinning, it's obviously reading SOME data, since it's showing the RHEL splash screen...so my question is, how do I get access to this data? I've tried booting Ubuntu LiveCD, but it doesn't see the drives.

How can I mount one of these drives within Linux, and get access to what data is still readable?

--- EDIT --- Ok, so I put the new SAS RocketRAID card into a different server that has CentOS5.5 installed. It has a Dell SAS card that controls those drives.

I installed the card, and just 1 drive. I then built the kernel module for the RocketRAID, per the company's instructions. When I boot, CentOS is recognizing the drive, I can go to /dev/scsi/rr272x_1x and see that the OS recognizes it (was seen as scsi 5, so it puts a file named '5' in this dir, and when I cat it, shows the drive info.)

But, still can't get at the data...

Tried mounting EVERYTHING shown in /dev/s* (sda, sda1, sda2, sdb, sdb1, sdb2).

Thanks for the answers so far, if anyone can assist further, I'd be much obliged!

  • Is the card identical to the one in there that failed?
    – DanBig
    Jan 25, 2011 at 20:20
  • No, it is not. Completely different brand.
    – mistiry
    Jan 25, 2011 at 20:37
  • What is the new card? Is it supported by Linux? The boot process is supported through the bios so that might explain why the drives aren't found by your livecd but it works just long enough to fail when booting directly from the drive.
    – DerfK
    Jan 25, 2011 at 21:45
  • New card is a High Point RocketRAID PCIe 2.0 x8.
    – mistiry
    Jan 25, 2011 at 22:28
  • What's the actual model number of your RocketRAID card?
    – DutchUncle
    Jan 25, 2011 at 22:38

1 Answer 1


Have you tried mounting one of the hard disks in a different machine (or setup the RAID card to run it as a JBOD and try the liveCD again), and recover your data that way?

Given that an alien RAID card can make sense of the existing RAID1 array, I'd say your chances are very high.

  • I tried putting the drives, first just 1 and then other then both, into another machine. No luck. Actually looking at the JBOD settings and stuff now. Thanks, will let you know.
    – mistiry
    Jan 25, 2011 at 22:27
  • Do you mean you tried to boot from them, or did you try investigate the partition table and mounting points from the operating system on the host machine?
    – DutchUncle
    Jan 25, 2011 at 22:40
  • I tried to boot from them...When I try, I get the RHEL splash screen, but then it fails, saying it can't find /dev/root, /proc, /sys and a few others. I can't get an operating system to see the drives to investigate the partition tables, etc.
    – mistiry
    Jan 26, 2011 at 15:20
  • Add 2 empty hard disks to your production server, install a fresh install of RHEL and then add the old hard disk to investigate: #1 if your old partition table makes any sense #2 what file system was used #3 mount your old slices/partitions #4 copy files. Done :-)
    – DutchUncle
    Jan 26, 2011 at 15:54
  • Ok, I found my partitions. I have 2, 1 is ext3 (type 83), the other is type 8e (Linux LVM). So, how can I mount a partition of that type?
    – mistiry
    Jan 26, 2011 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.