This is using CentOS 5.5. I have two dual port NICs on a server:

NIC1: eth0, eth1

NIC2: eth2, eth3

I have an ssh and vnc session open to the ip address on eth2. When I disable eth0 (ifdown eth0), my sessions to eth2 disconnect and I no longer receive a response when pinging that ip address. What could be happening?

  • eth0 and eth2 are on the same network, so I suspect data is coming in on eth2, but going out of eth0 due to the routing table. – PiNoYBoY82 Jan 27 '11 at 16:21
  • If they are on the same network, why not create a bond interface? – SpacemanSpiff Feb 4 '11 at 21:49

You can run tcpdump -i eth0 and see if the packets are going out via eth0 instead of eth2.

  • This would be my guess as well. you can disable it (so that connection replies go out the interface they originally came in on) with echo 0 > /proc/sys/net/ipv4/conf/eth2/rp_filter and/or add net.ipv4.conf.eth2.rp_filter = 0 to /etc/sysctl.conf – Patrick Feb 4 '11 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.