I'm running winXP and recently uninstalled AVG because the free trial had expired and I wanted to downgrade to the free version.

However, after a restart I found that I was not getting DHCP from my wireless router, I seemed to be getting DHCP from a server at giving me the IP These settings are completely new and give no network or internet access. The DHCP record is set to expire every 10 minutes.

If I manually set my IP to and the gateway & DNS to (the settings my router's DHCP should be giving me) I have complete internet access etc.

Other machines on the wifi network get DHCP from the router and connect absolutely fine so it seems to be a local problem.

How can I find out where these DHCP packets are coming from and get rid of it!

PS I've just found that I can ping fine. I don't understand what this device might be - nothing has been added to the network. Looking at the output of arp -a it's MAC address is 00-21-4c-13-4c-fb.

  • If it's a 10.x address, it can only be on your internal network, or even your PC itself. I'd make sure AVG is gone completely, and run a full scan of your machine for malware. – user3914 Jan 26 '11 at 23:22
  • Have you tried blacklisting that mac address on your router? Have you setup your wireless security using WPA2 and a strong password? – Zoredache Jan 26 '11 at 23:26
  • 1
    That shows up as a Samsung device, if that helps you narrow it down. – Dennis Williamson Jan 26 '11 at 23:27
  • Randolph - AVG free is installed and scanning now - nothing so far! – deanWombourne Jan 26 '11 at 23:28
  • Zoredache - WPA2 and strong password, check :) – deanWombourne Jan 26 '11 at 23:28

A quick internet search (looks like Dennis had the same idea from the comments) found it to be a Samsung device.

I thought I only had two (TV and Blu-ray player) both of which are not on the network.

Turns out that Virgin use Samsung for some of their boxes and it was acting as a DHCP server.

My router's lease timeout is set to 99 days so since we plugged the Virgin box in (at Christmas) all the other devices on the network already had IPs from the router and didn't need to get new ones.

Uninstalling AVG triggered a DHCP refresh on my machine which for some reason picked up the virgin box before the router. Hence only my machine getting invalid data.


Now to find out how to turn off DHCP on a Virgin+ box . . .

  • Browse to that address in a web browser and see if it has a configuration page. – Wesley Jan 26 '11 at 23:34
  • It doesn't - I tried that as soon as I saw it was sending DHCP responses :( It would be nice if it did though. – deanWombourne Jan 27 '11 at 9:18

Thanks for the info! I assume you manage to resolve this but just in case anybody else stumbles upon this thread as I did, I managed to resolve the issue by removing the ethernet connection between my router and V+ box. You can't switch DHCP off on the V+ box, especially if you want to use On Demand content, but you can remove the connection to the router. I was a little over zealous when plugging in my V+ box (there's a space for a network connection so I used it!) but the direct link to the cable is all you need. My setup had been working fine but for some reason my Samsung Omnia 7 starting pulling it's IP from the V+ box rather than the router, I would never have guessed it was the V+ box without this thread so thanks again.

  • 1
    That's exactly what I did - unplugging it just seemed easiest :) – deanWombourne Jun 6 '11 at 9:55

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.