I have the strangest problem. Our network (200ish machines on a ..254.0 subnet) are a mixture of XP and server OS's. All work fine. However, I have two new machines - both running Win7. Neither network propery via the edge switches (Cisco 2950) but work fine when hooking up directly to the server core switches (also Cisco - Catalyst 3750G ). The flakey behaviour on the edge switches is inability to ping anything other than itself, but it DOES pickup an address via DHCP, and are able to join the domain, validating credentials etc. (But not log into the domain - error No Logon Server Available)

When connected to the core switches everything works as expected.

I've tried ensuring windows firewall is off, giving valid static IP's, disabling IPV6 and some other general fiddling around all to absolutely no avail. There is no wireless network on this site.

Any ideas ?

  • 1
    Have you checked to switch ports to make sure they're configured as access ports, etc? – joeqwerty Jan 27 '11 at 16:53
  • Yes, and I can swap out a cable from a working machine to a new one. The ports are not locked to Mac addresses so this is totally throwing me. – Andiih Jan 27 '11 at 23:44
  • Can you paste the config for the access port? (sh run int f0/x) – HampusLi Apr 6 '11 at 12:12
  • I'm not on site at the moment, but the issue persists...next time I'm there I'll grab them. I've also been told there is a registry fix - I've not seen it/tried it yet. – Andiih Apr 6 '11 at 13:25

do the edge switches have 802.1x enabled? If so are the .1x settings configured properly on the client machine's NIC?

  • The edge switches dont have 802.1x enabled, although that certainly fits the behavior! – Andiih Jan 27 '11 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.