(I have also posted this on technet but I'm running out of ideas)

I've upgraded from Windows Server 2008 R2 Standard to Enterprise in order to make use of more RAM. The server previously had 32GB of RAM.

The upgrade from Standard to Enterprise, using DISM, seemed to go OK, so I powered down and installed the RAM. This a Dell Poweredge T710, I was taking it from 32GB to 72GB.

The BIOS recognised the RAM, although I needed to change from "Advanced ECC" to "Optimizer" mode for it to use all of it.

After rebooting, windows can see the RAM but in the system panel will display:

Installed memory (RAM): 72.0 GB (4.00 GB usable)

In the resource monitor, the remainder of the RAM is showing as reserved for hardware. I've tried various RAM configurations, including reverting it to the same chips and same configuration as before the upgrade, but always just 4.00 GB is showing up as usable. Following some threads on these forums I've gone into msconfig and set the maximum memory "by hand" but that doesn't fix the problem. BIOS doesn't seem to have anything that looks like memory remapping which is another suggestion that has come up.

How do I make this RAM available to Windows? It was available before the upgrade, because I could use the full 32GB RAM the server had to start with.

A screenshot (this is after reverting to the original RAM configuration)

enter image description here

I don't know if it's related, but my remote desktop configuration has also disappeared:


(the bottom half of this dialog should allow me to configure Remote Desktop, it was working before the upgrade but now it isn't).


I have found a temporary answer - but it gives me another problem. Here's what I just posted on technet, where I also asked this question:

OK, I have temporarily got round the problem - it's not the BIOS - but now I don't know how to fix it permanently.

The clue came from this thread, where C Clarke appears to have done the same things as me:

"We had "updated" these from Standard to Enterprise, using the DSIM utility and the generic KMS key available off of MS web site. We had then changed the license key, from the GUI to be a valid license key for Enterprise. After a reboot RDP was not working."

"Just now I reverted to the "generic" KMS key and everything is working..."

later on he says:

"Then I used another valid MAK key, and everything still worked. If I use the other one (which is now working on a completely rebuilt server), it doesn't - also says 4GB usable out of 48GB RAM....?.."

...exactly the same symptoms as me; only 4GB usable RAM, no RDP.

I've just changed the product key on our server to use the generic KMS key for Enterprise - and all is good. I have RDP, and I have 72GB RAM.

But - I'm now using a key for which I don't have a license. This server is purely for development and testing (right now we need to have 20 VMs up at the same time, hence the need for extra RAM beyond 32GB and therefore Enterprise).

Originally, the server came with a Dell OEM key for 2008 R2 Standard, it didn't start off with the MSDN key for 2008 R2 Standard.

So, my question now becomes - how do I apply the MSDN Enterprise key and still retain more than 4GB usable RAM, RDP, and perhaps other features that I didn't spot were missing?

Am I going to have to rebuild the server using the MSDN Enterprise key? Is it not possible to follow this upgrade path (OEM Standard Key -> MSDN Enterprise Key)?


Now I know what the real question is, I have asked it separately:

How do I upgrade Windows Server 2008 R2 Standard (OEM Key) to Enterprise (MSDN Key) using DISM?

  • Have you considered using Hyper-V Server? It's free (no key to worry about), will use the 72GB, and run 20 VMs easily. Just a though...
    – Chris S
    Feb 8, 2011 at 13:34

7 Answers 7


While I don't have a "here is your problem" answer, I do have a method of helping identify what may be the problem. Based off of what I'm reading here and what I can see on my own servers, Device Manager should be able to help you identify what's going on.

If you open Device Manager, change the view to "Resources by Connection" (not "Devices by connection"). The "Memory" node in there will give you a list of memory reservations by your hardware. Hopefully, the thing that's eating all but 4GB of your RAM will be listed in there. You'll have to convert the hex to RAM sizes, but it can be done.

Device Manger output

In this case, the first PCI bus entry is reserving 128KB. The second "Motherboard resources" entry is reserving 64MB. The third PCI Bus is consuming 336MB. And so on.

Once you've identified the device, you're further along than you started.

  • I will try this first thing in the morning (UK time)
    – Tom Crane
    Feb 1, 2011 at 0:13

I've answered this question in the linked question (the REAL question and root of the problem is about switching between OEM, KMS, and MSDN keys).

Here's how I got my server back:

Start with the server upgraded to Enterprise using the KMS Key. This for me is unlicensed.

Use the MSDN installation media (i.e., the burned ISO) and run the installer from within the current Windows instance. You can then reinstall Windows - make sure you pick the correct option so that you preserve existing files, application, settings etc.

After half an hour or so Windows will have finished installing. When you activate Windows, use the MSDN key, and all will work.

So, it looks like you can't switch keys between OEM/KMS/MSDN - you need to install Windows (or reinstall/update) from the appropriate installation media for the key to "take" correctly.


Regarding the missing remote desktop configuration, it may be possible that you need to install the Remote Administration feature.

The memory issue could be a problem with the BIOS properly reporting the memory configuration to Windows. You might want to update the BIOS if you haven't already. If you have time on your hands (and who does?) you might want to go back to the original amount of RAM and add a little at a time until the problem manifests.

  • I tried going back to exactly the same configuration (32 GB, same chips, same slots) as I started with before the upgrade but Windows still reports 32.0 GB (4.00 GB usable). And remote desktop worked fine before the upgrade.
    – Tom Crane
    Feb 1, 2011 at 0:12

IIRC Dell servers have an "installation mode" setting in the BIOS that limits the server to 4Gb available memory. You may want to see if someone has toggled that and if so, switch it off.


You may want to view the MSCONFIG | Boot tab | Advanced Options to verify the Maximum Memory setting.



I believe I have found resolution to this issue. I just ran into this exact problem and this put me on the right path. Below are the steps I performed to solve the issue and keep the proper licensing.

  1. Removed the current license with: slmgr /upk then slmgr /rearm
  2. Reboot the system.
  3. Enter the proper activation key.
  4. Reboot the system.
  5. Activation will fail via the web. You must call and activate via telephone activation.
  6. I Reboot this again to verify if the activation was persistent.

please follow below steps and reactivate your windows, it should resolve the issue-

  1. Open the command prompt and change working directory to System32 directory
  2. Type in slmgr.vbs -ckms (this clears and KMS entry you may have)
  3. Type slmgr.vbs -upk (this removes any product key installed)
  4. Type slmgr.vbs -ipk xxxxx-xxxxx-xxxxx-xxxxx-xxxxx (where the x’s is the new product key you want to use )
  5. Type slmgr.vbs -ato (this activates the server)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.