0

I am trying to set up a remote access VPN server to enable our employees to connect to the office network and access resources on it. In addition, several of our production servers (not located at the office) may only be administered from the office (locked down by IP), so I also need to be able to access the internet over this VPN.

I configured RRAS to allow VPN connections via PPTP, and have done all the necessary router/firewall configuration as well (just forwarded port 1723 and GRE to the server). I am able to connect to the VPN, but I do not have access to any network or internet resources.

From what I understand, the reason for this is that I have not configured routing. So my question is how do I configure routing for the VPN so I have access to the local network and the internet?

2

The problem in my case was that the server was assigning an IP address that was already in use to the remote access client. What clued me in that this was the problem was some warnings events seen in Event Viewer > Custom Views > Server Roles > Network Policy and Access Services.

The fix was to set up a static address pool of IPs that I knew were not in use. This is done on from the Routing and Remote Access Properties > IPv4 tab.

  • An additional problem I encountered was when using split tunneling on the client by unchecking the "Use default gateway on remote network" option so that regular internet traffic isn't sent over the VPN, Windows 7 was getting the routing tables wrong and sending nothing at all over the VPN. I was able to fix that by running a "route add" command on the client to specify that traffic targeted at the VPN's IP should use the VPN's gateway. Everything worked smoothly after that. – Triynko Sep 27 '12 at 17:31
1

In the RRAS management console make sure the server is configured for LAN routing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.