I'm trying to deploy an embedded system (NISE 110 by Nexcom) based on the Intel EP80579 (Tolapai) chip. Tolapai apparently integrates controllers for Ethernet etc. on a single chip (Intel homepage).

The machine can't get a network connection. Diagnosis as far as I could manage:


  • drivers from Intel compiled and installed without problems (version 1.0.3-144). Kernel version and Linux distribution (CentOS 5.2, 2.6.18) match the driver's installation instructions.
  • drivers are loaded and show up in lsmod (module names are gcu and iegbe)
  • interfaces eth0 and eth1 show up in ifconfig


  • I can bring up the interfaces with fixed IP
  • pinging the interface locally works
  • ifconfig shows flag UP but not RUNNING


  • ethtool shows "Link detected: no", "Speed: unknown (65536)" and "Duplex: unknown (255)"
  • Link LED is on
  • on the other side of the cable, ethtool shows "Link detected: yes" and reports a speed of 1000 Mbps, which has allegedly been auto-neogotiated with the problematic device.

Network traffic analysis

  • the device does not reply on ARP, ICMP echo or anything else (iptables is down)
  • when trying to send ICMP or DHCP requests, they never reach the other end
  • activity LED is off on the device, on at the other end.

I tried the following without any effect:

  • Different cables (2 straight, one crossed), I get the link LED lit up on each.
  • Three different devices on the other end (one PC, one netbook, one router)
  • Fixed ARP table entries on both sides
  • Connecting both network ports of the machine with each other, won't ping through the cable, but will ping locally. Tried straight and crossed cables for that.
  • Sounds like it might be a bad NIC.
    – mfinni
    Feb 2, 2011 at 14:25
  • Still sounds like a bad NIC to me.
    – mfinni
    Feb 3, 2011 at 16:57
  • @mfinni - I suspect there's something wrong with the driver or its setup. The device is brand new and there's two Ethernet "cards" on the chip. Any idea how I can distinguish a hardware from a driver issue? Feb 3, 2011 at 17:04
  • By having a second unit set up identically - if it works, the hardware is the problem. If it doesn't work, it's the config. Working with a single new piece of hardware without known-good configuration can be tough, so I could be wrong in my suspicion. Do you have access to the switch? Does the MAC for this device show up in the CAM table?
    – mfinni
    Feb 3, 2011 at 17:18

3 Answers 3


Ouch. This is what the Nexcom support said:

The NISE 110 uses dual Marvell GbE LAN ports, you will need to use the driver for these chips instead of the EP80579 driver.

So I had set up ethernet controllers (integrated in the Tolapai) that aren't wired to anything.

I'm very sorry, guys.

Confusion continues. After not being able to find any Marvell device, and after trying three different drivers that should work, I complained to support, who now researched some more and replied:

I apologise for the confusion on this issue. I have found more info that the Marvell chips are actually only transceivers, the LAN is through the EP80597.

And further:

HQ say that Linux compatibility isn’t good with the NISE 110, they have tested with RedHat 5 (CentOS 5) and still has some limitation, Note: Intel changed from RedHat 5 to CentOS 5. It may be best to use Windows XP Embedded

This is annoying, as we explicitly chose the box for its advertised Linux compatibility, and we need this component to be reliable, as we will deploy it on customer sites and we don't want to send service people all the time.

  • No worries, man. Mark this as the accepted answer for this question, in case someone else needs to find this out on their own.
    – mfinni
    Feb 7, 2011 at 17:47

does ethtool ethN report Link detected: yes?

Which driver are you using? I recall that for some Intel NICs, there are two possible drivers (e1000 vs e1000e), one of which does not work (well) for some chips.

  • I'm using the iegbe driver from intel.com/go/soc (the CentOS version). ethtool reports "Link detected: yes" on the other end, but not on the embedded system. Strangely, ethtool also can't seem to detect the speed (10/100/1000 MBit). The link LED on the Ethernet jack, however, seems to work fine. Feb 3, 2011 at 14:12

I would attempt to install OpenWrt 12.09 on the device and attempt the experiment again.

In the past I have made the iegbe drivers from openwrt work on in Redhat 6.4. One gotcha that I ran in to was that the PHY's were being matched to the incorrect MAC's.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.