I have a resource (a directory) on a Windows Server 2008 RS machine that I need to use as a web share on a Windows Server 2008 Server Standard machine running IIS. I am having trouble finding the right permissions to set for the resource to make it available on the IIS machine.

If I place the resource on the IIS machine it works fine, but I need it to work as a network share.

  • What is the error you receive? By RS do you mean R2? – Somantra Feb 2 '11 at 18:29

The likely cause here is the app pool identity has insufficient rights, if you are using pass-through authentication. Robert Kaucher also makes a good point in his suggestion. A UNC path won't be ambiguous, so when setting up the share, you may need to use a UNC path along with an app pool identity that can properly access said share.


On my Server 2008 R2 (IIS 7.5) network my sites are also running on '\\servername\some site' shares. What I have is:

  • A domain user account for the anonymous user (example domain.iusr)
  • In my Application Pool (advanced settings) I have this domain.iusr under Identity
  • Then in the website properties (basic settings) I use connect as feature to also login with domain.iusr
  • Because the connect as feature is used the user also needs write access to the Temporary ASP.net folder of the Framework you are targeting in your application pool. (keep in mind 32/64 bit version of framework) So if you have there for example 4.0 classic the user needs access in: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files (in my case I have 64 bits framework)
  • and ofc give domain.iusr read rights on your share (or more if needed)

Good luck!


Have you read this article?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.