3

I just fired a new amazon ec2 instance and i followed these directions and i get this when i visit the site

  File does not exist: /htdocs

also how do i get the elastic ip for this server because on the amazon console its blank

i cant tell what kind of ubuntu this is ..i see this

 Linux domU-12-31-39-02-5D-E7 2.6.31-302-ec2 #7-Ubuntu SMP Tue Oct 13 19:06:04 UTC 2009 i686
<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www
    <Directory />
            Options FollowSymLinks
            AllowOverride None
    </Directory>
    <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined

 Alias /doc/ "/usr/share/doc/"
 <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
     Deny from all
     Allow from 127.0.0.0/255.0.0.0 ::1/128
     </Directory>

    </VirtualHost>
2
  • Could you please post content of /etc/apache2/sites-available/default? – Alex Feb 4 '11 at 1:41
  • posted in my original post – Matt Elhotiby Feb 4 '11 at 2:09
4

figured out it was just that i forgot to enable the defualt vhost

 a2ensite default

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.