I am accessing my Server 2003 LAN from my Home PC via VPN. I installed the Remote Server Admin tools on my Windows 7 machine and I am able to browse the Active Directory users and computers with no problems. I go to open the Group Policy manager, right click on Group Policy Manager, add my domain and I get the message:

No mapping between account names and security IDs was done. I assume this is because my home computer does not belong to the domain, but is there a way around this message?


No real way around it as Campo indicated, but realistically you can just RDP into the domain controller and do your work there. It's easier anyway.

  • Was goiing to say RDP but felt due to his question RDP was not elegant enough and deleted that part. PLUS 1 – Campo Feb 4 '11 at 20:10
  • The problem here is that my DC is a Server 2k3 box, and my clients are Windows 7. There is no way to get the additional "Windows 7" Group Policy options onto my DC without modifying the GP from a Windows 7 box. – muncherelli Feb 5 '11 at 18:17
  • So it looks like you need to RDP or VNC into a local Windows 7 box or virtual machine? Or add a windows 2008 server to the network? – DutchUncle Feb 6 '11 at 1:39
  • Same issues over here. I run win 7 and our office servers are mainly 2k3. I created a 2k8 box to get around most of the issues (remote DNS, DHCP etc...) but till we upgrade our exchange the bulk has to be done with a RDP... Especially considering you are not on the domain feel that just adds 1 more level of complication. Just RDP and go full screen then its like you are almost there ;) I must edit my Exchange objects from the 2k3 box as 2k8 wont even allow me to do any exchange admin from the AD console on that box. – Campo Feb 7 '11 at 18:42

You should be able to do Run As on the individual RSAT tools and authenticate as your domain user account (i.e WIDGETS\Ben).

Hold Shift and right click on the tool and select Run as different user.

  • AH like the Run as Different user! – Campo Feb 4 '11 at 20:13
  • Only concern with this is; would he be able to authenticate as a domain user without being on the domain? If he is VPN in I would say yes but otherwise this solution would not work. – Campo Feb 4 '11 at 20:23
  • Yeah I actually tried this, but even authenticating as a user on the domain isn't the same as logging onto a computer that is "on" the domain. – muncherelli Feb 5 '11 at 18:13


Applies to XP but I assume the issues caused would be similar.

Other Idea would be that yes you must join the domain..... As you must provide proper credentials before being aloud to edit group policy. Therefore if you cannot provide those when launching GPeditor (run as administrator then specify domain credentials) then you would get that error....

Non elegant solution would be to VPN in then RDP the DC and edit the GPO using the DC GPeditor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.