Iam running Zend with Apache and got to see a strange behaviour....

If i type in my browser url, it works fine, but after typing: http://localhost, i will get a file download window, saying file type as: application/x-httpd-php

And in my httpd.conf file, i have the following under VirtualHost *:80 definition:

ServerName localhost

DocumentRoot E:\zend\Apache2\htdocs\my_project\public

Directory E:\zend\Apache2\htdocs\my_project\public

Perhaps some configuration problem... can anyone guide me..

  • What is the content of this file if has content? Is it a php script?
    – greg0ire
    Feb 5, 2011 at 11:23
  • It is not a php file, its name is something random string, like: FYJqRx7z.part, and its an empty file Feb 5, 2011 at 11:37
  • Attach httpd.conf. All path enclose in double quotes.
    – alvosu
    Feb 5, 2011 at 11:49
  • sorry i cannot attach the httpd.conf file... but can anyone tell me a reason for this? Feb 5, 2011 at 11:56
  • I pinged for> ping:localhost, it is fine, and pinging> ping: also is fine... Feb 5, 2011 at 12:57

2 Answers 2


from the httpd.conf file:

NOTE: Where filenames are specified, you must use forward slashes instead of backslashes (e.g., "c:/apache" instead of "c:\apache"). If a drive letter is omitted, the drive on which Apache.exe is located will be used by default. It is recommended that you always supply an explicit drive letter in absolute paths to avoid confusion.

so change the

DocumentRoot E:\zend\Apache2\htdocs\my_project\public


DocumentRoot "e:/zend/Apache2/htdocs/my_project/public"

the Directory E:\zend\Apache2\htdocs\my_project\public is the part of the config file in which services and features are allowed and/or disabled in that directory, so it has to go like this:

<Directory "e:/zend/Apache2/htdocs/my_project/public"> some options </Directory>

it would be easier to point out what's wrong if you would post the httpd.conf here, or upload it somewhere and post a link to that file

  • This doesn't explain why localhost doesn't work though Feb 5, 2011 at 19:48
  • getting an application/x-httpd-php file download window is a weird error, I'm doing my best here with the things dskanth submitted
    – addam
    Feb 5, 2011 at 19:53
  • Thanks for the answers... i got my problem solved now... i have restarted the zend server after making the change in DocumentRoot statement, as addam pointed, and localhost works now :) Feb 8, 2011 at 5:29

Check your hosts file, typically in someplace like:


Make sure that there is an entry for localhost like this: localhost

Frankly, I can't immediately see why the absence of such an entry would produce the result you report - a download of type application/x-httpd-php - but when something's not working, always best to dot all the i's and cross all the t's. ;-)

  • Yes, indeed that entry is present in my hosts file. Feb 8, 2011 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.