I'm attempting to implement cross-domain HTTP access control without touching any code.

I've got my Apache(2) server returning the correct Access Control headers with this block:

Header set Access-Control-Allow-Origin "*"                   
Header set Access-Control-Allow-Methods "POST, GET, OPTIONS" 

I now need to prevent Apache from executing my code when the browser sends a HTTP OPTIONS request (it's stored in the REQUEST_METHOD environment variable), returning 200 OK.

How can I configure Apache to respond "200 OK" when the request method is OPTIONS?

I've tried this mod_rewrite block, but the Access Control headers are lost.

RewriteEngine On                  
RewriteRule ^(.*)$ $1 [R=200,L]       

3 Answers 3


You're adding a header to a non-success (non-2xx) response, such as a redirect, in which case only the table corresponding to always is used in the ultimate response.

Correct "Header set":

Header always set Access-Control-Allow-Origin "*"                   
Header always set Access-Control-Allow-Methods "POST, GET, OPTIONS"

If you set a directory for authenticated access, browsers such as Chrome and Safari (maybe others too) always send an uncredentialed OPTIONS request before the XmlHttpRequest call, which always gets 401 and fails if we don't set the .htaccess file/apache configuration to allow OPTIONS method without requiring authentication. That drove me nuts for 2 days and that's the kind of "esoteric" information that webmasters keep as secret, I guess! Anyway I configured my .htaccess like this and now it works:

AuthUserFile <path to password file>
AuthName "Thou shalt not pass!"
AuthType Basic
Options -Indexes
<LimitExcept OPTIONS>
  Require valid-user

Then you have to set headers properly on the PHP scripts.

  • 1
    That last line is important. If the underlying web service can't handle the OPTIONS request, you will receive a 404 error. Jan 25, 2018 at 1:55
  • THANK YOU! This was driving me nuts too. Even worse, the combination of this R=200 rule with the redirect to an unauthorized path was somehow causing Apache to provide a useless "internal error" message rather than a more helpful 401. Jun 1, 2020 at 14:45

Sometimes this approuch can help:

<IfModule mod_headers.c>
    Header add Access-Control-Allow-Origin "*"
    Header add Access-Control-Allow-Headers "origin, content-type"
    Header add Access-Control-Allow-Methods "PUT, GET, POST, DELETE, OPTIONS"

RewriteEngine On                  
RewriteRule ^(.*)$ blank.html [QSA,L]

It is usefull when you have apache-like server

  • it unlocked requests for me. surprisingly. on apache 2.4 With this rule on blank.html that does't exist !
    – Nadir
    Sep 2, 2019 at 23:20
  • That caused a 400 Bad Request for me. Changing it to /blank.html fixed it. Jun 1, 2020 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .