2

I'm trying to export a report to PDF with a custom font.

I have installed a font on the server that hosts Reporting Services 2008 R2, restarted the SSRS service, and sucessfully seen it using the web frontend, exported it to Excel, however on PDF the font is not there.

On the Acrobat PDF file If I click on File -> Properties -> Fonts. I'm presented with a screen that shows me a list of fonts on the PDF.

There's an "a" icon with Helvetica-BoldOblique

Type: Type 1

Encoding: Ansi

Actual Font: Arial-BoldItalicMT

Actual Font Type: TrueType

The second one is a double T icon with the font I'm using and a (Embedded Subset) sufix.

Its a True Type font and ANSI encoded.

However the text is not using this embeded font, If I select the text and copy to a word document (I have the font installed) I can see the text in the font, however not on PDF, what's wrong here?

Here's how the Screen looks: Acrobat Font List

2

I've rebooted the server and it worked...

  • Hah! I came here hoping to find a solution that wasn't this. Can't win 'em all, I guess... – lunchmeat317 May 11 '15 at 21:08
  • Sorry about that, in my case it was a SQL Cluster, sometimes fonts aren't loaded on the reports, what I try to do is reinstall the fonts on both servers and rebooting them, altough this doesn't make sense, because I only use one server as reporting services. – Gabriel Guimarães May 12 '15 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.