1

I'm using Ubuntu 8.04 to share an nfs directory to some 10.04 clients. My intention is to have everything owned by Ubuntu's "backup" user (which should be the same name and uid on both machines, although the directions I followed have it matching just by names via idmapd).

I followed these directions with the exception of using "mount --bind" -- I just stored my share in the /export directory directly. https://help.ubuntu.com/community/SettingUpNFSHowTo

At first, I saw all the files, but they had a very long number as the user and group names/ids, so I realized I didn't have idmapd running correctly. After I restarted it, everything mounted ('df' shows the share as mounted) but now I don't see anything at all under the mount point.

Is this a bug between the versions of NFS in the different releases of Ubuntu, or should I fall back on NFS3, or is it (hopefully) just my misunderstanding the steps?

  • If you're not using kerberos for authentication, the uid and gid(s) must match for the users and groups. NFS's AUTH_SYS just sends along the uid and gid(s), and idmapd's job is to translate them into names. – beans Feb 7 '11 at 19:52
  • Thanks for clarifying that; good to know. The uid and gids do match. – AllanA Feb 8 '11 at 4:59
  • Send along the export options on the server and the mount options on the client from /proc/mounts. – beans Feb 12 '11 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.