Note: This is a VM on VMWare ESX server, but that should not matter

I put in the 2008 R2 x64 install dvd and can get to recovery, but it lists no Operating Systems. Clicking on Next brings me to

System Recovery Options
Choose a recovery tool
Operating system: Unknown or (Unknown) Local Disk

Command Prompt

I start the command prompt, go to C:\ and perform a dir /a

Apart from files I put there myself, these are showing

Documents and Settings [C:\Users]
Program Files
Program Files (x86)
System Volume Information

Where to go next? Is it like the NTLDR problem with Windows 2003 where I can just drop a file in there and it will be hunky dory again?

7 Answers 7


Try BCDBoot.

Boot from the windows CD then go to the command prompt.


BCDBoot c:\Windows
  • Thanks. I got it going by copying bootmgr from somewhere else. Seems like the same fix as the old W2k3 ntldr is missing issue. From a quick read, that looks like it does something similar to Vick's answer manipulating the bcd but doesn't mention recovering the bootmgr file Commented Feb 9, 2011 at 23:26

I have had an immense amount of trouble getting windows to boot on a new 1TB disk. It booted off the new drive so long as the old drive was plugged in to the first SATA port, but after a year of running like that the old drive finally died.

I followed the advice of @SLY and @JFB and also this useful hint on how to access the Startup Repair function under Windows 2008 R2 Server from the command line. (x:\sources\recovery\StartRep.exe)

After much trial and error I did get this machine to boot with only the new drive connected, so I can finally pull the aging OEM drive. As I don't really know exactly which step fixed it, I am just listing what I did below.

; Initial condition: will not boot, says "NTLDR IS MISSING". 
; Booting off Win2k8r2 install CD. In recovery window, no windows installations appear.
; From command line, partition is present and seems ok.

BCDBoot C:\Windows 

; after this step the windows 2k8r2 installation appears. Still fails on reboot.

Bootrec /rebuildbcd

; after this step it found an installation and allowed me to select it. Fails on reboot.


; startup recovery runs, claims to fix some stuff. Fails on reboot.

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

; One of these four commands fixed it. This time bootrec /rebuildbcd 
; did not find any orphaned installations, and StartRep.exe said that
; everything was fine.
; Rebooted one more time and it worked.

I had the same thing happen to me, here is what I did:

  1. boot with the W2k8 R2 DVD
  2. BCDBoot C:\Windows
  3. Bootrec /rebuildbcd

Fixed the problem, and now in msconfig (System Configuration) under the boot tab, I see all my Windows installations.


It appears that there was a D: drive that can be accessed in recovery mode and the bootmgr file is there!

This got me going again. Not sure if the bootrec /rebuildbcd from Vick's answer was required, but that was already attempted before copying the bootmgr file.

D:\> attrib -h -s -r bootmgr
D:\> xcopy bootmgr C:\
D:\> C:
C:\> attrib +h +s +r bootmgr

Although this post is rather old, here is a solution for those who have this problem in the future. This procedure was tested and does work (at least in my case) :

You will need a Windows 7 x64 DVD.

  1. Boot from your Windows Server 2008 R2 x64 DVD.
  2. Repair
  3. Command Prompt
  4. rename c:\boot\BCD bcd.old (if folder missing, don't mind and continue to next step)
  5. Delete c:\boot\bcd (if folder missing, don't mind and continue to next step)
  6. Restart your computer
  7. Remove your WS2008R2 DVD and install the W7x64 DVD.
  8. Boot from the DVD and do a repair.
  9. It will offer to repair automatically accept.
  10. Reboot and this is the "trick" boot the DVD again and do a repair. Keep doing this process until it does not find anything wrong.
  11. Your server should boot again.

Hope it helps


Try this: Type Bootrec /RebuildBcd while in repair mode, and then press ENTER.

if this will not work:

  1. Bcdedit /export C:\BCD_Backup
  2. ren c:\boot\bcd bcd.old
  3. Bootrec /rebuildbcd

Restart the computer.

Based on this

  • Thanks - it got me further. The OS is now listed in the first prompt when using repair from the dvd. However, still BOOTMGR is missing Commented Feb 9, 2011 at 22:45

You know why this fixed your problem? Because you have a recovery partition and obviously ignored it. You just needed to use diskpart and mark THE RECOVERY PARTITION (not Windows) as active.

  • 1
    that would have gotten me booted into D:, but I would still have had to copy the missing bootmgr from D: to C:, which was the real problem. How Windows can lose NTLDR or BOOTMGR is beyond me Commented Mar 22, 2011 at 23:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .