I added the Dreamhost's nameservers like 12 hours ago to:

I entered to the following panel:

Nameservers -> Set Nameservers (I have specific nameservers for my domains)

and added Dreamhost's nameservers liek this:

Nameserver 1: NS1.DREAMHOST.COM
Nameserver 2: NS2.DREAMHOST.COM
Nameserver 3: NS3.DREAMHOST.COM

So now in the admin panel I see this:

Nameservers:  (Last Update 2/10/2011)

But I get this when I run the analysis tools:

Attention Required! There are critical issues
Accessing Your Web Site
Accessing Your Web Site
Properly configuring your domain name and hosting account ensures that visitors can access your site.

Did I do something wrong or I have to wait 24 to 48 hours?

Dreamhost does display my page because I can access the other domain name I bought together with the hosting.

(By the way, if everyone uses the same nameserver, how will go GoDaddy know which is the hosting space that I purchased among all others)?

Thanks in advance.


My Dreamhost domain is http://alexchen.info/

My GoDaddy domain (the one I want to use ) is http://alexchen.co/

  • 1
    It would be somewhat easier to help you if you told us the domain name. Presumably you didn't register it to keep it secret, so hopefully you're OK with that. – MadHatter Feb 10 '11 at 22:09
  • And what's wrong with GoDaddy's nameservers? Why do you want your zone be delegated to Dreamhost? – Art Shayderov Feb 10 '11 at 22:33
  • Art: It's easier to use Dreamhosts nameservers in this situation. If he moves servers, adds a subdomain etc, then Dreamhost will update his records. – Antonius Bloch Feb 10 '11 at 22:44
  • @MadHatter I added that. Please heck the EDIT I included. – janooChen Feb 11 '11 at 4:58

Just to let you know, there are records, and they are propagating. Firstly the domain registration and delegation of the nameservers is OK:

[madhatta@www ~]$ whois alexchen.co @whois.nic.co
[Querying whois.nic.co]
Domain Name:                                 ALEXCHEN.CO
Name Server:                                 NS1.DREAMHOST.COM
Name Server:                                 NS2.DREAMHOST.COM
Name Server:                                 NS3.DREAMHOST.COM

Secondly, at least one nameserver at dreamhost is serving an A record for you:

[madhatta@www ~]$ dig alexchen.co @ns1.dreamhost.com
alexchen.co.        14400   IN  A

So that much is working. It seems to me that if you put up the alexchen.co site on, and the webserver there is configured to serve it, everything should work. I must also add that, when I point a web browser at alexchen.co, I see nice, shiny wordpress site looking back at me. What do you see?

What interests me is that your old domain is on a different address:

[madhatta@kiev systems]$ dig alexchen.info
alexchen.info.      14400   IN  A

I don't know the details of what you're trying to do, but is that what you expected? If so, can you confirm that you're still having the problems, and they weren't - as others have sensibly suggested - propagation delays?

You say you're on ubuntu, which should have both the tools I've used above, dig and whois; they're invaluable for trying to debug DNS issues.


You need to wait a bit longer. If you have tried to access it before it was ready it might also be your dns cache.

try ipconfig /flushdns on your computer.

Try querying an external dns server like googles as well.

nslookup domain.com

nslookup domain.com

If those are starting to return dreamhosts webserver ip then you are set, just wait it out.

When someone queries your domain, it will see that your nameservers are at dreamhost. If will query dreamhosts servers for your domain name, and they will return the information that correctly responds to your website. This way multiple servers can use the same name server.

  • is that commando for windows? (I'm on Ubuntu). – janooChen Feb 11 '11 at 5:02
  • that should work on ubuntu as well. if not use dig. linux.die.net/man/1/dig – pablo Feb 11 '11 at 9:21

While 12 hrs is sometimes long enough, it can take anywhere from 24 to 48 hours for DNS to propagate across the Internet.

Give it a bit more time.

What are you using for your analysis tool.

A simple website that is powerful and full of great tools

http://www.network-tools.com check it out

  • Lorentz Godaddy's Diagnostic View. – janooChen Feb 11 '11 at 5:01
  • I just checked out both of those sites using the network-tools site above and both are coming back with good data. Looks like you are good to go. ;) – Tom Feb 11 '11 at 16:39

Well the analysis tool doesn't really tell you much in the way of what's wrong, but my guess is that while you do have NS records for your domain you do not have any other records for your domain. Is there an A record for the domain? Is there an A or CNAME record for www?

Not the answer you're looking for? Browse other questions tagged or ask your own question.