We are two users in the office which regulary use RDP to connect to client computers. But we have discovered a problem.

Whenever one of us is connected to a remote computer using RDP, the other user cant connect to any external computer using RDP.

And when one user disconnects from his RDP session, the other user is able to connect to RDP again.

I understand there are limitations on how many users that can connect to the same RDP session, but in this case we try to connect to completly different computers using RDP.

May this be a problem in our firewall, or what might cause this?

  • How are you connecting to the remote computer? Some kind of VPN? And is the no-connection problem limited to RDP or are you unable to e.g. ping any other remote computer when one connection is already established? – Stephan Keller Feb 11 '11 at 8:31
  • Usually we connect IP to IP, no VPN involved. We have not tried to ping when one of us is using RDP, I'll try that. – Martin Feb 11 '11 at 8:40

This issue is almost certainly to do with the NAT setup of your router, essentially it's only letting the RDP return path talk to one internal IP.

There are a number of ways you could deal with this, without knowing your exact router and setup it would be hard to be specific but in this case I would warn away from trying to move the port used on the second external machine - it may seem obvious but RDP is a very well known and used protocol and that path would be more likely to cause problems in itself than resolve this on. Ultimately I suggest you deal with this in the more structured way of looking at your NAT config, put this detail on here by all means, and looking for a way to configure it better for this scenario. Worst case scenario however is that your router may not be able to do this and you may have to look elsewhere, thought I'd warn you up front.

Hope this helps.

  • 1
    Thanks, you where right. There was an old NAT rule in the router that blocked the RDP conenctions. – Martin Feb 19 '11 at 11:27
  • Glad you fixed it. – Chopper3 Feb 19 '11 at 11:43

Has to be your firewall. RDP ispretty simple (TCP connection only). Check whether there are limits (I think it is port 3389). I have seen the same with PPTP, but that is not "just a pure tcp connection".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.