I'm trying to set up email on my server, and have successfully set up POP3 with gmail for my main account. When attempting to set up another user though, gmail reports ` There was a problem communicating with example.com. I can't figure out why it's working for me and not the other users. I do receive email sent to the address on the server.

One suggestion I found online was to try logging in over telnet, but strangely, it kicks me off right after I log in.

nona~$ telnet example.com 110
Connected to example.com.
Escape character is '^]'.
+OK Dovecot ready.
user frank    
pass password
+OK Logged in.
Connection closed by foreign host.

thanks for any ideas and help


Turns out the problem was that the user didn't have a home directory, so I think Dovecot was silently failing when it couldn't find/write to the user mailbox.

Giving the user a home directory solved the problem.

| improve this answer | |
  • +1 for letting us know you solved the problem! – larsks Feb 12 '11 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.