I have a Solaris 11 machine running inside the LAN. It is a default install. I can access the machine and ping it if I ssh into my router (if it matters, it is running dd-wrt). I cannot ping the Solaris machine using ip address from any other machine inside the LAN.

But if I setup port forwarding everything works perfectly fine. I can also use the port forward from outside the LAN (from my office) - which is good and how I want it to be. I can SSH and ping and do pretty much everything else from outside as well as inside but only as long as I have the port forwarded from my router.

Why would I not be able to ping or ssh or even access the Solaris 11 machine from within the LAN - I have checked and couldn't find any firewall running on the Solaris 11 box. I even tried disabling every known firewall on the router (dd-wrt, it had something like SPI firewall running). I even tried setting a static IP for my Solaris box but all in vain! Please help me understand how and why this happens!!


3 Answers 3


How are you certain it is the Solaris box is responding when you ping from the outside?

Your router I'm assuming is a SOHO device, which means a WAN port and a 4-5 port switch for the LAN. When hosts connected to the LAN side need to talk to each other, they may go through the router's "hardware" but they talk to each other directly unless you've decided to carve that up into VLANs.

So... what I'm trying to say is, most like the problem is the firewall on the Solaris machine. I cannot explain why when you port forward SSH works, perhaps the firewall on the Solaris machine trusts the default gateway.

  • I know that the Solaris box is responding from the outside, because I get the ping response and I can ftp, ssh etc. So if there may be a firewall on the Solaris 11 host, how can I detect that that is indeed the issue and how do I turn it off. Running netstat on the Solaris 11 host does not seem to indicate any firewall running, maybe there is a better way.
    – Anoop
    Feb 13, 2011 at 19:56
  • I'm not very familiar with Solaris, so I don't know where to point you. On most *nix systems the firewall is IPTABLES or maybe IPF. Look in /etc for an ipf or iptables config file. What does your IP addressing look like? Feb 13, 2011 at 22:57

You need to allow ICMP. ICMP type 8 is needed to respond to ping

  • I can ping fine, but that works only if I have a port forwarded.
    – Anoop
    Feb 13, 2011 at 19:54

Are you sure that the response for the ping from the outside is being done by your solaris server? I think that the ping response is of the DDWRT router

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.