24

I'm using RHEL 5.6 and unzip-5.52-3.el5. I'm trying to unzip a big file, but I get the error:

unzip -o test.zip -d unzip/
error:  Zip file too big (greater than 4294959102 bytes)
Archive:  test.zip
warning [test.zip]:  4294967296 extra bytes at beginning or within zipfile

Is there another program that can work with large zip files or do I have to wait until unzip 6 comes to RHEL? (might be years!)

Thanks

43

If you've got Java on the box, you can use

jar xf test.zip
  • 1
    saved me from having to bug the SAs to install unzip6. Thanks! – plor May 15 '13 at 20:19
  • 1
    life saved. [ beer token ] – Ade Oct 14 '13 at 22:17
  • I had a 16+GB zip file downloaded from my wife's phone using AirDroid, and this trick saved me a lot of trouble! – Bob Bell Oct 10 '14 at 18:52
5

I've found good success with 7-zip, it appears they have a fedora core build as well that might work for you, the downloads can be found at http://www.7-zip.org/download.html. Failing the fedora one, you can download the source and/or binary and try that.

  • I played around with 7-zip (7z), but when extracting files from my zip it kept saying unrecognised format. – Noodles Feb 15 '11 at 1:54
  • 1
    Check if 7z isn't an alias for 7zr. Try running 7za. – Hubert Kario Feb 15 '11 at 3:36
  • 1
    The package p7zip-full ships a command 7z, which accepts the x (extract) option. So in my case, using '7z x huge.zip' worked without issue. – RemusKaos Jul 24 '17 at 11:22
  • 7z fails for me, says the file is corrupt. The most upvoted jar answer did work though – David Waterworth Oct 24 at 2:14
5

You can either use javas jar, or (in my opinion) even better: 7-zip. Most distros allow for it to be installed from repos, so you can use for example (on ubuntu):

sudo apt-get install p7zip-full
7z x huge.zip

Note how the command is not p7z or p7zip, but only 7z. Also the x option has no preceding -. Best of luck!

  • This answer has already been given 6 years ago. – Gerald Schneider Jul 24 '17 at 11:43
  • This method worked for me with a 16GB zip — I trust the jar method also works but did not try that. Thanks. – userabuser May 12 '18 at 2:38
  • 1
    @GeraldSchneider This answer helped me regardless of when it was answered. – Mercurial Oct 11 at 7:08
4

I finally ended up rolling my own rpm's for unzip 6, they can be found here: http://www.noodles.net.nz/2011/02/15/unzip-6-for-rhel-5-6/

-2

I tried all the steps mentioned above to unzip the file, but failed miserably.

My last resort was to copy my zip file (11.1GB) into a hard drive and unzip it using 7 zip on Windows 8 OS.

Worked like a charm :D

  • 1
    That is not an answer to this question. – Cory Knutson Jun 14 '17 at 19:18
  • I tried in more ways than one to get it running on Linux... None of the solutions worked... So I'm giving a better alternative... Much more easier and hassle-free alternative.. – Vinu Joseph Jun 19 '17 at 7:21
  • Beyond 4 GB, linux is unable to unzip files... Windows I'm afraid has a much better mechanism to unzip huge zip files... So just giving out that info... – Vinu Joseph Jun 19 '17 at 7:23
  • No it's not, silly. Read above. Just don't use /bin/unzip – Warren P Jan 31 '18 at 23:56
  • 1
    jar xf file.zip or 7z x file.zip and others are fine – Warren P Jan 31 '18 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.