65

We switched from PostgreSQL 8.3 to 9.0. Perhaps it's a new feature or perhaps just a configuration change, but now when output from commands (like, \d tablename) exceeds visible vertical space, psql seem to pipe the output through something similar to less. I could not find a way to turn this behaviour off. Any advice? Thanks.

P.S. I'm scrolling the buffer using PuTTY's Shift+PgUp/PgDn so I don't need psql's paging. Plus, when I press q in the psql's paging, its output disappears from the screen entirely (just like after running less in bash), which is wrong from the general use-cases point of view.

1
  • 1
    If you're here from Google just trying to scroll through the pager, it's Space -- not n or PgDn or down arrow like I tried.
    – Noumenon
    Dec 29 '16 at 15:51
60

TL;DR:

\pset pager 0

From the \pset section of the psql manual:

pager

Controls use of a pager program for query and psql help output. If the environment variable PAGER is set, the output is piped to the specified program. Otherwise a platform-dependent default (such as more) is used.

When the pager option is off, the pager program is not used. When the pager option is on, the pager is used when appropriate, i.e., when the output is to a terminal and will not fit on the screen. The pager option can also be set to always, which causes the pager to be used for all terminal output regardless of whether it fits on the screen. \pset pager without a value toggles pager use on and off.

7
  • 11
    Thank you. The complete solution looks like: psql -P pager. Feb 14 '11 at 9:50
  • 3
    I guess you can even put an option in your ~/.psqlrc file to avoid having to enter this every time.
    – Sven
    Feb 14 '11 at 9:52
  • 3
    I also ran into Yuri's problem. As described above. You can use \pset pager in psql to toggle whether the output goes to the pager. However, you should be able to use a pager and not have the output disappear from the screen when you quit. The answer is to use 'more' instead of 'less' as the pager. You can either do that by setting the PAGER environment variable in your shell or by adding a PAGER environment variable to a ~/.psqlrc file. Apr 4 '14 at 16:29
  • 5
    @MichaelRush: Set PAGER to less -X and it won't clear the screen.
    – Sven
    Apr 4 '14 at 16:40
  • 1
    For others, here's what the -X (or --no-init) option to less does: Disables sending the termcap initialization and deinitialization strings to the terminal. This is sometimes desirable if the deinitialization string does something unnecessary, like clearing the screen. Apr 25 '14 at 0:53
26

Try switcher:

database_name=# \pset pager
Pager is used for long output.
database_name=# \pset pager
Pager usage is off.
1
  • 3
    Also \pset pager [on|off] for constant result.
    – lolesque
    Jul 16 '15 at 16:27
17

To turn off the pager when using psql in the shell :

psql -P pager=off ...

You could also export an empty PAGER environment variable, so you don't need to add the option to every statement. It will stay set until you close your current shell.

export PAGER=
psql ...

Finally, a workaround that may be easier to remember: pipe the output through cat, which will disable the default pager

psql ... | cat
10

Switch the pager off with

\pset pager off
0
7

add below code in ~/.psqlrc to retain the behaviour

\pset pager off

2

Best way in summary is to set an environment variable for the pager, e.g.

PAGER='less -X' psql

or to set it once

export PAGER='less -X'

then run

psql

1
  • 1
    From the man page: -X or --no-init - "Disables sending the termcap initialization and deinitialization strings to the terminal. This is sometimes desirable if the deinitialization string does something unnecessary, like clearing the screen." Aug 31 '20 at 3:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.