i think i am missing some basic knowledge about network connectivity, maybe someone out there could explain me, why the following causes problems. The facts:

  • We are connected to the "internet" with 100mbit/s, full duplex.
  • We had the cable of our internet provider connected to a security appliance (Cisco ASA): outside- and inside-port where configured to both 100mbit/s, full duplex.
  • Behind the security appliance we had a 24-port 10/100/1000mbit/s switch. The port connected to the ASA was configured to be 100mbit/s, full-duplex ... the other ports where configured to be 1000mbit/s

Internal bandwidth between the machines connected to the switch was always very good. Incoming bandwidth was always ok. Outgoing bandwidth was ok until after two years suddenly the outgoing bandwidth dropped down to below 1mbit/s.

At first we thought we had a problem with our ASA, because we detected lot's of CRC errors on the outside-port of the appliance. We swapped the hardware, but the bandwidth problem was not solved.

We than changed the configuration of the inside-port of the ASA to 1000mbit/s, full duplex and the port of the switch to 1000mbit/s, too ... so that every port of the switch now has 1000mbit/s.

This not only solved our bandwidth problem, it's even better than before. Apparently we had some kind of bandwidth-mismatch because of the different configuration in the switch ... but i am not really sure, why ... is there some "easy" explanation for this kind of problem?

Thanks in advance!

| improve this question | | | | |

The problem is exactly as you describe so I am not sure exactly what you are looking for an answer.

You have a duplex mismatch.

More information:


| improve this answer | | | | |
  • Thanks, i think i wanted to know the opinion of someone who would have probably more knowledge than me about all this. Btw.: i found netperf to be an excellent tool to debug such bottlenecks. – harald Nov 18 '11 at 11:40
  • Edit: I get it now; setting the mode on only some of the ports caused other devices connected to those ports to fail auto-negotiation and fall-back to half-duplex mode. – apraetor Sep 19 '16 at 14:16

As a rule of thumb I always MANUALLY set every port to be at its maximum speed, I know it's a contentious issue around here but I don't trust auto-speed/duplex detection. I can't comment on you exact situation without further information but I suspect there was a port speed issue and also that perhaps your ASA is doing some form of caching perhaps that, when set to GigE allowed for this performance increase. Well done either way.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.