This is probably a very basic question, but I'm hopping someone can explain what's going on to me.

I configured our wireless router at work to connect to directly to the router that provides our internet connection. I set the wireless router up with a static ip address and set the gateway to be the router it is connected to.

All of the wireless computer's set their dns and gateway to the wireless routers IP and everything is working.

Just for fun I ran traceroute google.com on one of the wirelessly connected computers.

I expected the results to be

  1. Wireless Router
  2. Wired Router
  3. everything else ...

instead it seems to skip the wireless router entirely and looks like

  1. Wired Router
  2. Everything else ...


  • 1
    Take a look at the routing table on one of the wireless clients. On a Windows client run the following from a command prompt: route print. – joeqwerty Feb 16 '11 at 3:12

My best guess is your Wireless router isn't actually routing but bridging so it wouldn't show up on a traceroute.

| improve this answer | |
  • seems the most obvious answer. – Phil Hollenback Feb 16 '11 at 0:18
  • I can't find anything suggesting the router is working as a bridge, but I'll keep looking. One thing I found was that it is set up to act as a DNS Relay (help file says: When DNS Relay is enabled, the router plays the role of a DNS server. DNS requests sent to the router are forwarded to the ISP's DNS server. This provides a constant DNS address that LAN computers can use, even when the router obtains a different DNS server address from the ISP upon re-establishing the WAN connection. You should disable DNS relay if you implement a LAN-side DNS server as a virtual server.) Could that be it? – evan Feb 16 '11 at 0:34
  • @evan: The DNS settings of either or both routers shouldn't have any bearing on the routing functions of either router. – joeqwerty Feb 16 '11 at 1:07
  • @evan I'd say .. the easiest way to tell is to look at the ip address/subnet/default gateway of a wired and a wireless client. If they are on the same network the router is bridging not routing. – Zypher Feb 16 '11 at 3:35
  • @Zypher Sorry it took long to get back to you, and thanks for your help! The static ip settings for the wireless are different than for the wired network. The wireless gives out ip as a 10.x.x.0/24 private network and the wired gives 128.x.x.0/24 public addresss. (The router itself has a 128.x.x.x address but the wireless devices point to it as the default gateway at 10.x.x.1) Which is why I think it's so strange 10.x.x.1 wouldn't be the first route on the traceroute? – evan Feb 16 '11 at 18:32

It is possible to "stealth" a router to traceroutes by configuring it to not decrement the TTL of packets it forwards (for example, here is a discussion of such in the Juniper docs). Check your router's config to see if that's what's happening.

| improve this answer | |
  • thanks for your reply, I'm checking the settings to see if I can find out if that's what it's doing! – evan Feb 16 '11 at 0:35
  • If that were the case the OP should still see the wireless router as the first hop. Tracert will send the first batch of packets with a TTL of 1, so if the wireless router were routing, the first response would either be a response from the wireless router or * * * * if the wireless router was ignoring the ICMP packets. Yes? – joeqwerty Feb 16 '11 at 2:01
  • @joeqwerty: If the wireless router is not decrementing TTL, then it would still forward TTL=1 packets to the next hop, wouldn't it? Maybe I've misunderstood the semantics of routers w.r.t. TTL? – Steven Monday Feb 16 '11 at 6:12
  • I see what you're saying. If the wireless router ignores the TTL of the first tracert ICMP packets and simply forwards them to the next hop then maybe the wireless router wouldn't show up in the tracert. But then it really is bridging and not routing? I've set up routers to act as bridges between subnets before but then they act like layer 2 switches instead of layer 3 routers. – joeqwerty Feb 16 '11 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.