I've got a Solaris (Nexenta) NAS box that I'm trying to create multiple VLAN subinterfaces for.

Currently, I've got an LACP aggregated link set up on the network to my switch (Cisco 3750). The switch port-channel interface is in access mode on VLAN 118, so the NAS only sees one network.

What I want to do is to make the NAS VLAN-aware and enable it to communicate on VLAN 118 and 999. In theory, to do this, I need to enable 802.1Q VLAN trunking on the aggregated interface, create subinterfaces for vlan's 118 and 999 and assign the network to 118 and the network to 999.

I've tried to do this in the past by unplumbing aggr1, creating the vlan interfaces with dladm create-vlan and then trying to plumb in the two new vlans that were created. However, when I assigned the addresses to the vlan interfaces and put the switchport in trunking mode, there didn't seem to be any network connectivity - I couldn't ping other devices on the network from the vlan interface.

Have I missed a step somewhere?

$dladm show-link
igb0        phys      9000   up       --         --
igb1        phys      9000   up       --         --
aggr1       aggr      9000   up       --         igb0 igb1
pub0        vlan      9000   up       --         aggr1
priv0       vlan      9000   up       --         aggr1
  • What say "dladm show-vlan", "dladm show-aggr" and "dladm show-phys" ? – jlliagre Feb 17 '11 at 6:11

Wouldn't you just do this to create the VLAN interfaces on aggr1:

ifconfig plumb aggr118001 plumb
ifconfig plumb aggr999001 plumb

I don't have a create-vlan option to dladm. What Solaris version is that?

| improve this answer | |
  • I'm on Nexenta, so snv134. I've managed to get it working with the vlans on a single physical interface (no lacp aggregation), but aggregation still fails. – growse Feb 16 '11 at 21:51
  • That would explain it. My latest install is snv111b. So, plumbing the interfaces like above doesn't work? That's how we've done it on earlier Solaris versions. It's VLAN ID * 1000 + instance. – JOTN Feb 17 '11 at 0:06
  • I would say there are some plumbs too much in the commands. – ceving Jul 17 '17 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.