This problem occurs on fedora core 12. So I was trying to setup a named dns server on a central node and on the surface it looks like it works (ping resolves, nslookup LOOKS like it gives correct info?), but I think I set it up wrong because hostbased passwordless ssh is having problems. The goal of the DNS server was to be a centralized internal DNS server for resolving names on the cluster and nothing else.

Here's what happens when I am on a machine and try to ssh into itself. Normally this works. Im pretty sure the issue is DNS related because when I add c0-0 to /etc/hosts, it all works because /etc/hosts has precedence over dns according to nsswitch.

Notice the getnameinfo error in the verbose ssh output. http://pastebin.com/qSWFDtqf

Here's the same without the debug: http://pastebin.com/svZmvakR

relevant named.conf lines (on central node): http://pastebin.com/J08MPgBS

relevant cluster.dns lines (on central node): http://pastebin.com/mtATKn1e

relevant /etc/hosts.equiv lines (i tried different variations of the hostname to see maybe if that was it): c0-0

Like I said I'm pretty sure the error is in cluster.dns because I'm quite confused by the proper syntax. Does anyone see something trivial that I do not? Do I need to setup reverse DNS?

  • 2
    A little bit of a shot in the dark but, have you created reverse DNS records for these cluster nodes? – rthomson Feb 17 '11 at 20:15
  • haha, I had just come in here to say that I'm 99% sure it's the lack of reverse DNS. I got one successful passwordless login. – Realn0whereman Feb 17 '11 at 20:30
  • Drop ssh from the troubleshooting and use dig to do a direct query on your DNS server to see if it is responding properly. Let us know what dig shows for the hostnames. You can use 'dig c0-0 @ip.of.dns.server' to query the server directly. – Dave Drager Feb 17 '11 at 20:39
  • Yup, it was the lack of reverse DNS. It wasn't hard to slap together a script to map the existing /etc/hosts file into their respective forward and reverse dns zones. Thanks guys :P – Realn0whereman Feb 17 '11 at 21:31

So the problem was missing reverse DNS. I usually disable DNS resolving for SSH every since I once tried to access my servers during a time where DNS was dead.

It took ages to log in - and I don`t like to be dependent from other infrastructure services that are not directly connected to the main purpose of my server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.