Folks, I'm facing a very weird problem with one of my production servers(it's Debian Lenny) - after reboot network interfaces(eth0,eth1) are in DOWN state.

Looks like an Intel based networking adapter is installed on the server, lspci lists it as follows:

Ethernet controller: Intel Corporation Device 10c9 (rev 01)

The kernel driver responsible for this adapter is "igb". lsmod shows that "igb" module is present. I tried "modprobe -r igb && modprobe igb", network interfaces first disappear then appear, but they are in DOWN state again.

What could go wrong? It used to be working just fine. How can this be fixed?

I'm using KVM IP and can't really copy the full dmesg output from the Java Applet. Running "dmesg | grep eth" shows nothing unusual, here is its output:

[    2.137021] igb 0000:05:00.0: eth0: (PCIe:2.5Gb/s:Width x4) 00:25:90:1d:3e:c2
[    2.137100] igb 0000:05:00.0: eth0: PBA No: 0100ff-0ff
[    2.320508] igb 0000:05:00.1: eth1: (PCIe:2.5Gb/s:Width x4) 00:25:90:1d:3e:c3
[    2.320587] igb 0000:05:00.1: eth1: PBA No: 0100ff-0ff

UPDATE: Some additional information about the server. I'm using OpenVZ patched version of the kernel but I think it has nothing to do about it. I tried to boot using the non patched version of kernel and nothing changed, interfaces are still DOWN.

But that's not the full story. Even "lo" interface is DOWN. lsmod shows that loop module is running. I tried "modprobe -r loop && modprobe loop" but loop device is still DOWN.

  • 1
    Add /var/log/syslog,kernel.log,message and dmesg output
    – ooshro
    Feb 18, 2011 at 6:15
  • I have kvm ip access to the server and I have no idea how to copy stuff from that console(it's a Java applet which doesn't allow to copy'n'paste :( ). I'm looking at dmesg and it says nothing bad about eth stuff, just usual stuff.
    – pachanga
    Feb 18, 2011 at 7:27
  • Check with ethtool if they are physically down. Why did you reboot the server? In case the reboot was because of a new kernel consider doing a rollback to the old version.
    – pehrs
    Feb 18, 2011 at 7:44
  • ethtool is not available :( I did the reboot of the server in order to test the failover procedure, emulating the crash of the server(I was testing Heartbeat). And again the server was working just fine before.
    – pachanga
    Feb 18, 2011 at 8:22
  • What's in your /etc/network/interfaces file? Feb 18, 2011 at 12:14

1 Answer 1


I have found the answer to this problem.

My network was in DOWN state after reboot because... /sbin/ifup was missing. I played with installing some packages from the "testing" repository using aptitude and it looks like it removed the "ifupdown" package! And /etc/init.d/networking quietly exits if /sbin/ifup is missing. That's why I could not manually enable network interfaces.

This is how I fixed this weird situation. First, I enabled networking by manually running "ifconfig up lo", "ifconfig up eth0". Second, I assigned addresses to these interfaces by running "ip a add ...". Third, I setup the default route using "ip route add ...". And in the end I reinstalled the "ifupdown" package using apt-get.

  • Rather old, but still relevant it seems: Upgrading two Debian buster systems to bullseye one system failed to bring up ethernet afterwards. Your hint on the ifupdown package - right on the spot. It seemingly got lost in the middle of a 150+ package purge; and everything back to normal after the simple reinstall.
    – hasienda
    Jan 10, 2023 at 13:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .