2

I am having issues using svn all of a sudden. When trying to update/commit or create a new checkout I get the following error. I cant seem to find much information about it.

svn: OPTIONS of 'https://username@svn.host.com/svn/repos/project/TRUNK': SSL negotiation failed: SSL error code -1/1/336032856 (https://svn.host.com)

any idea?

7
  • What happens if you try loading that URL in a browser? Do you get a more meaningful error message? Also, is this a Subversion server that you control, or are you interacting with it strictly as a client?
    – larsks
    Feb 18, 2011 at 18:37
  • I have no issues connecting through a browser. This is a server that we do control. Do you think this has to do with my openssl version .9.8l being higher than the servers openssl version .9.8e?
    – slik
    Feb 18, 2011 at 19:03
  • I tried upgrading to the latest openssl on the client side. Still same issue occurs.
    – slik
    Feb 18, 2011 at 22:00
  • Can you telnet to that address using port 443 and then issue a GET command? Reason being is if you see readable text, you are sending unencrypted data through an SSL layer. If you don't see readable text, ssl is working fine and we can continue to diagnose from there. Feb 18, 2011 at 22:16
  • Just tested on my box, you can see readable text, but you should get an error like this: Reason: You're speaking plain HTTP to an SSL-enabled server port. Feb 18, 2011 at 22:24

2 Answers 2

1

What is the output of "openssl s_client -connect svn.host.com:443" from the client running svn?

1
  • Alternatively, get a network capture to see which phase of the handshake is failing.
    – Nasko
    Jun 24, 2011 at 16:30
0

I received the same error message when my Apache configuration was wrong - my ServerName parameter in httpd.conf did not match hostname in the self-signed certificate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.