I have recently tried to use gmail through google apps as my main email client, but I'm experiencing a few different problems.

I am managing the domain (conjunktiondesign.co.uk) through 123reg.co.uk but it is hosted through fasthosts.co.uk. I transfered the domain to 123reg as fasthosts did not allow me to change the MX records myself.

I followed the setup instructions step by step on google apps and changed the MX records as they told me to. My email was now working perfectly but my website was down and I was getting the following error:

The dnsserver returned: No DNS records

I have a friend that is using the same system as me (ie. Externally hosted domain and google apps mail) and I changed my 123reg details to the same that he had (as his was working perfectly - both email and website).

I changed my name servers to point to fasthosts, rather than 123reg and I added an A record called '@' pointing to fasthosts IP address. I also created another A record called 'www' pointing to fasthosts IP address.

After I did this, my website worked almost immediately but I have only realised that since changing it my email is now down. I have not received anything since Saturday.

I am a web designer and would consider myself fairly tech savvy, but I have no idea about A records, CNAME's and all the things I have been messing about with!

What I ultimately need is someone to help me get my email and website working at the same time, rather than one being down when the other is OK. I seem only able to get one or the other working. I have now changed the name servers back to 123reg in an attempt to get my email back as it is more important than my website at this stage.

Any help is much appreciated.



Please share you zone file because on doing a DNS lookup I am getting the following results. From what it looks like the problem lies with the DNS entries.

Can you make a simple DNS entry like this in your zone file.

www A IP_OF_WEBSERVER and then check

$ dig @ns2.123-reg.co.uk conjunktiondesign.co.uk

; <<>> DiG 9.7.1-P2 <<>> www.conjunktiondesign.co.uk ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 58696 ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION: ;www.conjunktiondesign.co.uk. IN A

;; AUTHORITY SECTION: conjunktiondesign.co.uk. 1572 IN SOA ns.123-reg.co.uk. hostmaster.conjunktiondesign.co.uk. 2011022102 86400 3600 1209600 86400

;; Query time: 77 msec ;; SERVER: ;; WHEN: Mon Feb 21 21:22:00 2011 ;; MSG SIZE rcvd: 103

  • I have added the DNS entry as you said and these are the results I got in Terminal... $ dig @ns2.123-reg.co.uk conjunktiondesign.co.uk ; <<>> DiG 9.4.3-P3 <<>> @ns2.123-reg.co.uk conjunktiondesign.co.uk ; (1 server found) ;; global options: printcmd ;; connection timed out; no servers could be reached I don't really understand that stuff. Do you? – Jonathan Kelly Feb 21 '11 at 16:21
  • I'm not sure what you mean by sharing my Zone file? – Jonathan Kelly Feb 21 '11 at 16:52
  • can you let me know how I can share my zone file. Thanks – Jonathan Kelly Feb 22 '11 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.