I'm having some issues setting up and using a vhost.conf for one of my domains. So far none of the domains have required any extra configuration but now I need to use a PEAR module, so I'm looking to include /usr/share/pear in the PHP settings for the domain.

vhost file created in /var/www/vhosts/domain.com/conf/vhost.conf

<Directory /var/www/vhosts/domain.com/httpdocs>
 php_admin_value include_path ".:/usr/share/pear"

I then restart Plesk using:

/usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=domain.com

Or as plesk says that command is obsolete in Plesk 10 I've tried using

/usr/local/psa/admin/sbin/httpdmng --reconfigure-domain domain.com

And for good luck I've restarted apache too each time. Net result - none of the PEAR includes work unless I edit the include_path in /etc/php.ini!

Any tips on how to get this MOFO working? I've had a look through the documentation but TBH I just don't have time to read 40 pages of Plesk manual for one line of code, this can't be that hard, surely!

Thanks for any pointers, H

  • 1
    Did you ever find the answer to this? I am having the exact same issue. I have added a vhost.conf but the settings never get applied. I don't get it. – meschu Mar 9 '11 at 5:00
  • Hmm no I'm afraid - in the end we didn't need to use vhost.conf - I made a workaround within php.ini. It's annoying though, where the hell is the documentation for this? – MrFidge Mar 15 '11 at 9:26
  • Oof - yeah I'll try and dig that out for you! Sorry I normally do post back the answers. --EDIT-- Ahh it was simply to add in .:/usr/share/pear to the global php include_path. All our applications and domains on the server could make use of it safely so there was no absolute need to allow/deny it on a domain by domain basis. – MrFidge Aug 3 '11 at 9:00

Since this is one of the top results on Google for "plesk vhost.conf restart", and I could not find useful instructions elsewhere, I will share my experience.

I needed to add this to my Apache/Plesk configuration to allow larger uploads:

<IfModule mod_fcgid.c>
    FcgidMaxRequestLen 52428800

So I put that exact content into a new file at:


To get this file included in the Plesk-generated conf files, I used something like:

/usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=domain.com


/usr/local/psa/admin/sbin/httpdmng --reconfigure-domain domain.com

The result of these commands is that Plesk adds a line like this:

Include "/var/www/vhosts/domain.com/conf/vhost.conf*"

to the generated httpd.include file, such as


I needed to restart apache for this to take effect:

/etc/init.d/httpd restart

And I checked the Apache error log to make sure it had no problems restarting.


In Plesk 10, I typed:

/usr/local/psa/admin/sbin/websrvmng -a

And it worked. It outputs a message about it being deprecated, but it still works. The -a means reconfigure all domains.

Not the answer you're looking for? Browse other questions tagged or ask your own question.