1

When I have attempted to build virt-viewer 0.2.x on CentOS, I had a build problem:

virt_viewer-viewer.o: In function `viewer_resize_main_window':
/root/virt/virt-viewer-0.2.0/src/viewer.c:285: undefined reference to `gtk_widget_get_window'
/root/virt/virt-viewer-0.2.0/src/viewer.c:286: undefined reference to `gtk_widget_get_window'
collect2: ld returned 1 exit status
make[2]: *** [virt-viewer] Error 1
make[2]: Leaving directory `/root/virt/virt-viewer-0.2.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/virt/virt-viewer-0.2.0'
make: *** [all] Error 2

I've unsuccessfully studied many Google-related sources. What can I do?

0

I was able to get this to compile under CentOS 5.5 but I downloaded version 0.3.1 which is the latest release. I had to comment out line 135 in src/display-vnc.c:

/* gdk_window_beep(GTK_WIDGET(viewer->window)->window); */

or you get:

make[2]: Entering directory `/root/virt-viewer-0.3.1/src'
  CC     virt_viewer-display-vnc.o
display-vnc.c: In function ‘viewer_bell’:
display-vnc.c:135: warning: implicit declaration of function ‘gtk_window_beep’
display-vnc.c:135: warning: nested extern declaration of ‘gtk_window_beep’
  CCLD   virt-viewer
virt_viewer-display-vnc.o: In function `viewer_bell':

This gave me a working virt-viewer, but I have no way to test this:

# src/virt-viewer -V
virt-viewer version 0.3.1

This and this seem very relevant. Hope this helps.

Announcement on the 0.3.1 release.

| improve this answer | |
  • Also, I had to install libglade2-devel and some other devel packages using yum from the standard CentOS repo. – timd Feb 23 '11 at 23:42
  • I did it, build successful – Andrew Shelikhanow Feb 25 '11 at 9:24
  • But, when I click on VM and go ti's properties, I've received run-time error: Traceback (most recent call last): ... File "/usr/lib/python2.4/site-packages/virtinst/VirtualVideoDevice.py", line 33, in init parsexml, parsexmlnode, caps) TypeError: __init__() takes at most 2 arguments (5 given) Please assist, how to solve this problem? – Andrew Shelikhanow Feb 25 '11 at 9:25
0

Try installing following packages using :

$ yum install gtk+-devel
$ yum install xulrunner-devel
| improve this answer | |
  • I try it, but these packages already installed – Andrew Shelikhanow Feb 23 '11 at 21:30
  • Rebuilt attempt with make clean then ./configure will no effect – Andrew Shelikhanow Feb 23 '11 at 21:31
  • Try the second one. Have you already installed xulrunner-devel? Also, you tried gtk+-devel, not just gtk+, right? – Sagar Feb 23 '11 at 21:34
  • Already installed – Andrew Shelikhanow Feb 23 '11 at 21:34
  • 1.9.2.13 centos v. 5.5 – Andrew Shelikhanow Feb 23 '11 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.