I am trying to follow the tutorial here to setup the user and pass. It says there that "this section is only applicable if your MySQL server is running with --skip-show-database". First question is, how do I check if MySQl server is running with --skip-show-database?

Is there any way I can access phpMyAdmin SQL query window without logging in? Otherwise I'd have to execute this SQL from command line.

I am also getting this:

Cannot load mcrypt extension. Please check your PHP configuration.

I have added mcrypt.so to php.ini and doing the following command proves that I have it.

[root@DT html]# rpm -qa | grep mcrypt
[root@DT html]# php -v
PHP 5.3.5 (cli) (built: Feb 19 2011 13:10:09)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

Now when I go to phpinfo() and search for mcrypt it can find it inside the Configure Command row ('--with-mcrypt=shared,/usr'). So, what to do next?.

UPDATE: I didn't put extension=mcrypt.so in php.ini as it will complain the following:

PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0

Here's my nginx.conf:

#user  nobody;
worker_processes  2;

#error_log  logs/error.log;
#error_log  logs/error.log  notice;
#error_log  logs/error.log  info;

#pid        logs/nginx.pid;

events {
    worker_connections  1024;

http {
    include       mime.types;
    default_type  application/octet-stream;

    #log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
    #                  '$status $body_bytes_sent "$http_referer" '
    #                  '"$http_user_agent" "$http_x_forwarded_for"';

    #access_log  logs/access.log  main;

    sendfile        on;
    #tcp_nopush     on;

    #keepalive_timeout  0;
    keepalive_timeout  65;

    gzip  on;

    server {
        listen       80;
        root         /usr/share/nginx/html;
        server_name  localhost;

        #charset koi8-r;

        #access_log  logs/host.access.log  main;

        location / {
            #root   html;
            index  index.html index.htm;

        #error_page  404              /404.html;

        # redirect server error pages to the static page /50x.html
        error_page   500 502 503 504  /50x.html;
        location = /50x.html {
            #root   html;

        # proxy the PHP scripts to Apache listening on
        #location ~ \.php$ {
        #    proxy_pass;

        # pass the PHP scripts to FastCGI server listening on
        location ~ \.php$ {
            #root           /usr/local/nginx/html;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME  /usr/share/nginx/html$fastcgi_script                                                                                                                               _name;
            include        fastcgi_params;

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one

        location ~ /\.ht {
            deny  all;

    # another virtual host using mix of IP-, name-, and port-based configuration
    #server {
    #    listen       8000;
    #    listen       somename:8080;
    #    server_name  somename  alias  another.alias;

    #    location / {
    #        root   html;
    #        index  index.html index.htm;
    #    }

    # HTTPS server
    #server {
    #    listen       443;
    #    server_name  localhost;

    #    ssl                  on;
    #    ssl_certificate      cert.pem;
    #    ssl_certificate_key  cert.key;

    #    ssl_session_timeout  5m;

    #    ssl_protocols  SSLv2 SSLv3 TLSv1;
    #    ssl_ciphers  ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP;
    #    ssl_prefer_server_ciphers   on;

    #    location / {
    #        root   html;
    #        index  index.html index.htm;
    #    }

  • Can you add your nginx config file here? – Andrew M. Feb 27 '11 at 20:28
  • I've added my config... I don't actually have a phpmyadmin under a new server config... should I have it? – EquinoX Feb 27 '11 at 21:38
  • You check phpinfo() in nginx or conlose(cli)? – ooshro Feb 28 '11 at 8:37

Create script /usr/local/nginx/html/test_mcrypt.php:


Then open http://servername/test_mcrypt.php. If your see bool(true), then problem in web browser cache.

Then edit /usr/local/nginx/html/test_mcrypt.php:


And find mcrupt section

  • I am getting false here.. where is that libraries/auth/cookie.auth.lib.php? I am now using ubuntu – EquinoX Feb 28 '11 at 8:22
  • Look like mcrypt module don't load. Check phpinfo(), I update answer. – ooshro Feb 28 '11 at 8:38
  • no mcrypt find there anywhere – EquinoX Feb 28 '11 at 8:43
  • Add to "/etc/php5/cgi/php.ini" line "extension=mcrypt.so" and restart php – ooshro Feb 28 '11 at 8:50
  • it says the loaded config file is /etc/php5/fpm/php.ini, is there something wrong – EquinoX Feb 28 '11 at 8:58

I noticed the users on this post ran into similar problems; have you restarted Apache, and tried clearing your browser's cache?

  • I am using nginx not apache... I have restart it like many2 times. Tried on 2 different computers and same issue – EquinoX Feb 27 '11 at 18:47
  • Ah, s/Apache/nginx/; principle is the same, since the issue is with PHP, not the web server. :) I'm sorry that wasn't the issue... I'll see if I can't find anymore solutions. – Andrew M. Feb 27 '11 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.