I have been unable to send email to users on hotmail or other Microsoft email servers for some time. Its been a major headache trying to find out why and how to fix the issue.

The emails being sent that are blocked from my domain canadaka.net. I use Google Aps to host my regular email serverice for my @canadaka.net email addresses. I can sent email from my desktop or gmail to a hotmail without any problem. But any email sent from my server on behalf of canadaka.net is blocked, not even arriving in the junk email.

The IP that the emails are being sent from is the same IP that my site is hosted on: This IP is new to me since August 2010, I had a different IP for the previous 3-4 years.

This IP is not on any credible spam lists http://www.anti-abuse.org/multi-rbl-check-results/?host=

The one list spamcannibal.org my IP is listed on seems to be out of my control, says "no reverse DNS, MX host should have rDNS - RFC1912 2.1". But since I use Google for my email hosting, I don't have control over setting up RDNS for all the MX records.

I do have Reverse DNS setup for my IP though, it resolves to "mail.canadaka.net".

I have signed up for SNDS and was approved. My ip says "All of the specified IPs have normal status."

Sender Score: 100 https://www.senderscore.org/lookup.php?lookup=

My Mcafee threat level seems fine

I have a TXT SPF record setup, I am currently using xname.org as my DNS, and they don't have a field for SPF, but their FAQ says to add the SPF info as a TXT entry. v=spf1 a include:_spf.google.com ~all

Some "SPF checking" tools ive used detect that my domain has a valid SPF, but others don't. Like Microsoft's SPF wizard, i think this is because its specifically looking for an SPF record and not in the TXT. "No SPF Record Found. A and MX Records Available".

From my home I can run "nslookup -type=TXT canadaka.net" and it returns:

Server: google-public-dns-a.google.com Address:

Non-authoritative answer: canadaka.net text = "v=spf1 a include:_spf.google.com ~all"

One strange thing I found is i'm unable to ping hotmail.com or msn.com or do a "telnet mail.hotmail.com 25". I am able to ping gmail.com and many other domains I tried. I tried changing my DNS servers to Google's Public DNS and did a ipconfig /flushdns but that had no effect. I am however able to connect with telnet to mx1.hotmail.com

This is what the email headers look like when I send to a Google email server and I receive the email with no troubles. You can see that SPF is passing.

Delivered-To: [email protected] Received: by with SMTP id q12cs91243yae; Sun, 27 Feb 2011 18:01:49 -0800 (PST) Received: by with SMTP id uu7mr4292541icb.68.1298858509242; Sun, 27 Feb 2011 18:01:49 -0800 (PST) Return-Path: Received: from canadaka.net ([]) by mx.google.com with ESMTP id uh9si8493137icb.127.2011.; Sun, 27 Feb 2011 18:01:48 -0800 (PST) Received-SPF: pass (google.com: domain of [email protected] designates as permitted sender) client-ip=; Authentication-Results: mx.google.com; spf=pass (google.com: domain of [email protected] designates as permitted sender) [email protected] Message-Id: <[email protected]> Received: from coruscant ([]:12907) by canadaka.net with [XMail 1.27 ESMTP Server] id for from ; Sun, 27 Feb 2011 18:01:29 -0800 Date: Sun, 27 Feb 2011 18:01:29 -0800 Subject: Test To: [email protected] From: XXXX Reply-To: [email protected] X-Mailer: PHP/5.2.13

I can send to gmail and other email services fine. I don't know what i'm doing wrong!


I have been removed from hotmails IP block and am now able to send emails to hotmail, but they are all going directly to the JUNK folder.


I used Telnet to send a test message to port25.com, seems my SPF is not being detected. Result: neutral (SPF-Result: None) canadaka.net. SPF (no records) canadaka.net. TXT (no records)

I did have a nameserver as my 4th option that doens't have the TXT records since it doens't support it. So I removed it from the list and instead added wtfdns.com as my 4th adn 5th nameservers, which does support TXT.

Now that the new nameservers have taken affect, I pass the SPF check email along with Microsofts SenderID Wizard. Seems some lookups were using the 4th nameserver and skipping the first 3???


canadaka.net. SPF (no records) canadaka.net. 86400 IN TXT "v=spf1 a include:_spf.google.com ~all" canadaka.net. 86400 IN A _spf.google.com. SPF (no records) _spf.google.com. 300 IN TXT "v=spf1 ip4: ip4: ip4: ip4: ip4: ip4: ip4: ip4: ip4: ip4: ?all"


canadaka.net. SPF (no records) canadaka.net. 86400 IN TXT "v=spf1 a include:_spf.google.com ~all" canadaka.net. 86400 IN A

  • 1
    It seems all my server and SPF setup was fine, Hotmail did have my IP blocked. I found a contact email for the "JMR Program Management Team" and they put me in contact with the "Windows Live Hotmail Sender Support Team" who verified my IP was blocked and submitted a fix to remove the IP which will take 24-48 hours. So we'll see if that fixes the problem. they also added my domain to the "Sender ID program". It was a very fast response, I'm impressed!
    – Canadaka
    Feb 28, 2011 at 4:36
  • I'm glad to hear you got it straightened out. I'm confused though, your telnet test (as a comment to my answer) was successfull, so how is it that you were being blocked?
    – joeqwerty
    Feb 28, 2011 at 12:00
  • I guess i'm being blocked by a filter or IP block after the connection is message is delivered. Might be nice if Hotmail blocked the connection or sent a mail undeliverable message so one was more clear they are 'blocked' by hotmail.
    – Canadaka
    Feb 28, 2011 at 22:06
  • Well I just sent a test message to hotmail and it went through!!! But it went straight to the Junk Mail folder, but at least it was accepted. Now to figure out why its going straight to junk, says "Microsoft SmartScreen marked this message as junk and we'll delete it after ten days." Will see if adding the 2nd SPF record to my Reverse DNS subdomain helps.
    – Canadaka
    Feb 28, 2011 at 22:15

5 Answers 5


Your title says your email is being blocked by hotmail.com but in one of your comments to Stony's answer you state that your SMTP log shows "RCPT=OK" and "RECV=OK" when sending email to hotmail.com. That in and of itself should be telling you that your email is not being blocked. It's being accepted by hotmail.com and is most likely being filtered after being accepted. there's a difference between an email being blocked/rejected and being filtered after being accepted.

You state that you can't telnet to port 25 of mail.hotmail.com. That's because mail.hotmail.com is not an MX for hotmail.com. A quick nslookup shows the following MX records for hotmail.com: mx1.hotmail.com, mx2.hotmail.com, mx3.hotmail.com, and mx4.hotmail.com.

You state that you can't ping hotmail.com but you can ping gmail.com. It's irrelevant whether or not you can ping hotmail.com or any other server, name, web site, etc. The ping tool doesn't test the availability of a service (web, email, etc). The fact that you can't ping hotmail.com only means that the hosts that hotmail.com resolve to don't respond to pings or that a firewall is blocking those pings. It's totally irrelevant to the problem. In addition, pinging hotmail.com has nothing to do with the MX records for hotmail.com. Hotmail.com is the domain name and pinging hotmail.com is pinging the A records configured for that domain name. When you ping gmail.com you're pinging the A record for that domain name, you're not pinging the MX records for gmail.com.

Have a look at the Hotmail Postmaster page here to see if there's anything you need to look in to:


  • I realize all of that, I just had read in another thread to test doing a nslookup to hotmail.com. I am however able to do an nxlookup to mx1.hotmail.com. I have been through that troubleshooting page several times and before posting on serverfault. I also seem to have no connection trouble when sending a test email over telnet.
    – Canadaka
    Feb 28, 2011 at 2:22
  • 220 canadaka.net <[email protected]> [XMail 1.27 ESMTP Server] service ready; Sun, 27 Feb 2011 18:15:00 -0800 HELO canadaka.net 250 canadaka.net MAIL FROM:<[email protected]> 250 OK RCPT TO:<[email protected]> 250 OK DATA 354 Start mail input; end with <CRLF>.<CRLF> SUBJECT:Test Telnet test from command line . 250 OK <SC>
    – Canadaka
    Feb 28, 2011 at 2:23
  • @Canadaka, it's apparent you're having trouble grasping basic mail server concepts. You should contact a local consultant who can help you troubleshoot your situation and help you understand where the problem is.
    – Chris S
    Feb 28, 2011 at 3:11
  • I've been running my own mail servers since 2001, I think I know the basics :P My IP was being blocked by Hotmail, see my comment to the original post. Since I changed locations in the data-center and got a new IP last august, its possible the IP was recycled and the previous user had gotten it blocked on hotmail.
    – Canadaka
    Feb 28, 2011 at 4:39

My issue was fixed by contacting Microsoft and they had to manually remove a block on my IP. Once the block was removed emails from my server were reaching Hotmail, but going directly to junk mail.

I have created a separate question to try and resolve the junk mail problem: Hotmail marking messages as junk


ok so for understanding. You want send an email from your google account [email protected] with an other FROM adress? Something like [email protected]?

But when your server send direct the mail over sendmail for example and you know that they don't come to the other site check the mail log if you have access. There you can see the complete connection to the other site.

  • No no, all emails are from [email protected]. Really the fact that I use Google Apps to host my personal [email protected] email service should have no effect. Its not used at all in the sending of an email from my webserver using PHP. I have looked at the SMTP logs on my server and I can see that the emails sent to [email protected] are sent out with no errors.
    – Canadaka
    Feb 28, 2011 at 1:12
  • ok so you connect with apache/php over smtp to your email account and send it over this? Or direct from your local server? Edit: Ok when there are no errors the other site has eccepted the connection and take the mail. Can you copy the line? Feb 28, 2011 at 1:19
  • My server runs Windows Web Server 2008 and PHP. I am using Xmail as my SMTP server and PHP sends the emails connecting to it on the localhost. I have been using this setup for years and there are no problems sending to other non-hotmail servers. This is my PHP.ini settings [mail function] ; For Win32 only. SMTP = localhost smtp_port = 3000 sendmail_from = [email protected]
    – Canadaka
    Feb 28, 2011 at 1:28
  • In the Xmail SMTP logs it says "RCPT=OK" and "RECV=OK". So it seems hotmail has accepted the connection and the received it...
    – Canadaka
    Feb 28, 2011 at 1:30
  • ok but this looks good. I think the mail is send. Perhaps the user has a spamfilter and the email is send there. But i have partial the same problems with Yahoo. Feb 28, 2011 at 9:11

You want to update that SPF record to include your web server's IP address ( Right now, the SPF only mentions gmail. You send mail from gmail -and- your web server.

  • 1
    the servers IP is inculded in the SPF, that is what the "a" is for. WHen I send an email to a NON-hotmail server I can view the email headers and see that SPF passes! Received-SPF: pass (google.com: domain of [email protected] designates as permitted sender) client-ip=;
    – Canadaka
    Feb 28, 2011 at 2:06
  • I'm confused, reading the google forums it seems some people suggest adding "_spf.google.com" and others say "aspmx.googlemail.com".
    – Canadaka
    Feb 28, 2011 at 23:24
  • I created a thread on the Google Forums to find this answer: google.com/support/forum/p/Google+Apps/…
    – Canadaka
    Feb 28, 2011 at 23:30
  • per Google Enterprise support, I've been using "include:aspmx.googlemail.com" in my SPF record for a few years now.
    – Chris_K
    Mar 1, 2011 at 2:16
  • It seems the "_spf.google.com" works It passed a test email to port25.com. Seems _spf is a wildcard for all the google mx servers or something.
    – Canadaka
    Mar 1, 2011 at 2:35

My DNS show your rDNS is broken for mail.canadaka.net. Perhaps it is pointing to the old IP address. spf_query shows no applicable policy for either the helo name or mail-from.

Consider adding 'v=spf1 a -all' as a text record for mail.canadaka.net. Also add the appropriate SPF record for canadaka.net. Perhaps 'v=spf1 a:mail.canadaka.net mx ~all'.

  • I also found this an hour ago, I contacted my data-center to update the reverse DNS to point to canadaka.net which points to the same IP. This was a mistake, I used to have mail.canadaka.net point to my server but now that I use Google Apps, it points to google mail.
    – Canadaka
    Feb 28, 2011 at 4:42
  • Is it better to point the Reverse DNS to just "canadaka.net" or something like "server.canadaka.net"?
    – Canadaka
    Feb 28, 2011 at 4:45
  • It is better to have it something like mail.canadaka.net. I believe the PTR record for this already exists. mail.canadaka.net points elsewhere, fix your A record and I think you will be OK. Host names like example.com are almost always spam sources, and often forged. Host names like mail.example.com is more likely to be sending ham.
    – BillThor
    Feb 28, 2011 at 4:50
  • I would suggest you change the name your mail server to a subdomain like mail.canadaka.net. You may want to send a message to [email protected] to verify your configuration. The message they send back will give you a good idea of any problems. You may need to wait for your DNS changes to propagate first.
    – BillThor
    Feb 28, 2011 at 5:04
  • I changed the Reverse DNS to "server.canadaka.net" and that has propagated. So now i'm going to add a 2nd SPF "server IN TXT "v=spf1 -all". I didn't want to use mail.canadaka.net because I use that as a CNAME to ghs.google.com for webmail access. Thanks!
    – Canadaka
    Feb 28, 2011 at 22:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .